cbcvebase.
CVE-2017-3167
published 2017-06-20

CVE-2017-3167: In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may…

PriorityP264critical9.8CVSS 3.1
AVNACLPRNUINSUCHIHAH
EPSS
20.23%
97.5th percentile
In Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26, use of the ap_get_basic_auth_pw() by third-party modules outside of the authentication phase may lead to authentication requirements being bypassed.

Affected

34 ranges· showing 25
VendorProductVersion rangeFixed in
apachehttp_server>= 2.2.0 < 2.2.332.2.33
apachehttp_server>= 2.4.0 < 2.4.262.4.26
apache_software_foundationapache_http_server——
apache_software_foundationapache_http_server——
applemac_os_x< 10.13.110.13.1
applemacos_high_sierra_10.13.1_security_update_2017-001_sierra_and_security_update_20——
debianapache2< apache2 2.4.25-4 (bookworm)apache2 2.4.25-4 (bookworm)
debiandebian_linux——
debiandebian_linux——
oraclesecure_global_desktop——
redhatenterprise_linux_desktop——
redhatenterprise_linux_desktop——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_eus——
redhatenterprise_linux_server——
redhatenterprise_linux_server——
redhatenterprise_linux_server_aus——
redhatenterprise_linux_server_aus——
redhatenterprise_linux_server_aus——
redhatenterprise_linux_server_aus——

Detection & IOCsextracted from sources · hover to see the quote

  • →Authentication bypass occurs when third-party Apache httpd modules call ap_get_basic_auth_pw() outside of the authentication phase; monitor for unexpected successful authentications or access to protected resources without proper auth phase processing ↗
  • →A remote attacker could exploit this to bypass required authentication; monitor for unauthorized access to Basic-Auth-protected resources in Apache httpd access logs ↗
  • →Upstream fix commits can be used to identify patched vs. unpatched binaries: 2.4 fix at commit 78f0f0b6585f13ec1175c7020ee01cd0237fc1ba, 2.2 fix at commit 7103baa2e70e37eeaf7847abaa6f3567ef2cdf73 ↗
  • ·Vulnerability only manifests when third-party modules incorrectly use ap_get_basic_auth_pw() outside the authentication phase; vanilla Apache httpd without such modules is not directly exploitable via this code path ↗
  • ·Affected versions are Apache httpd 2.2.x before 2.2.33 and 2.4.x before 2.4.26; detections should be scoped to these version ranges ↗
  • ·The fix introduces a new ap_get_basic_auth_components() function for safe use by third-party modules; presence of this symbol in a loaded module indicates patched behavior ↗

CVSS provenance

nvdv3.19.8CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
nvdv2.07.5HIGHAV:N/AC:L/Au:N/C:P/I:P/A:P
osv9.8CRITICAL
vendor_debian9.8CRITICAL
vendor_redhat9.8CRITICAL
vendor_ubuntu9.8CRITICAL
Stop checking back — get the weekly exploitation signal.

Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.