cbcvebase.
CVE-2018-14719
published 2019-01-02

CVE-2018-14719: FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and…

PriorityP261critical9.8CVSS 3.1
AVNACLPRNUINSUCHIHAH
EPSS
9.68%
95.5th percentile
FasterXML jackson-databind 2.x before 2.9.7 might allow remote attackers to execute arbitrary code by leveraging failure to block the blaze-ds-opt and blaze-ds-core classes from polymorphic deserialization.

Affected

57 ranges· showing 25
VendorProductVersion rangeFixed in
debiandebian_linux——
debiandebian_linux——
debianjackson-databind< jackson-databind 2.9.8-1 (bookworm)jackson-databind 2.9.8-1 (bookworm)
fasterxmljackson-databind>= 0 < 2.9.8-12.9.8-1
fasterxmljackson-databind>= 0 < 2.9.8-12.9.8-1
fasterxmljackson-databind>= 0 < 2.9.8-12.9.8-1
fasterxmljackson-databind>= 0 < 2.9.8-12.9.8-1
fasterxmljackson-databind>= 0 < 2.4.2-3ubuntu0.1~esm22.4.2-3ubuntu0.1~esm2
fasterxmljackson-databind>= 2.0.0 < 2.6.7.32.6.7.3
fasterxmljackson-databind>= 2.7.0 < 2.7.9.52.7.9.5
fasterxmljackson-databind>= 2.8.0 < 2.8.11.32.8.11.3
fasterxmljackson-databind>= 2.9.0 < 2.9.72.9.7
oraclebanking_platform——
oraclebanking_platform——
oraclebanking_platform——
oraclebanking_platform——
oraclebusiness_process_management_suite——
oraclebusiness_process_management_suite——
oracleclusterware——
oraclecommunications_billing_and_revenue_management——
oraclecommunications_billing_and_revenue_management——
oracledatabase_server——
oracledatabase_server——
oracledatabase_server——
oracledatabase_server——

Detection & IOCsextracted from sources · hover to see the quote

  • →Block polymorphic deserialization of blaze-ds-opt and blaze-ds-core classes in jackson-databind to prevent arbitrary code execution ↗
  • →Exploitation requires the blaze-ds gadget jars to be present on the classpath; absence of blaze-ds libraries renders the vulnerability unexploitable regardless of jackson-databind version ↗
  • →Review upstream patch commit 87d29af25e82a249ea15858e2d4ecbf64091db44 for the exact class-blocklist additions to use in detection/prevention logic ↗
  • ·Vulnerability only affects jackson-databind 2.x versions before 2.9.7; upgrade to 2.9.7 or later (e.g., 2.9.8) to remediate ↗
  • ·Exploitation requires polymorphic deserialization (e.g., default typing) to be enabled in the application's jackson-databind configuration; applications not using this feature are not directly exploitable ↗

CVSS provenance

nvdv3.19.8CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
nvdv2.07.5HIGHAV:N/AC:L/Au:N/C:P/I:P/A:P
osv9.8CRITICAL
vendor_debian9.8CRITICAL
vendor_redhat9.8CRITICAL
vendor_ubuntu9.8CRITICAL
Stop checking back — get the weekly exploitation signal.

Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.