CVE-2020-24994
published 2021-03-23CVE-2020-24994: Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code…
PriorityP346high8.8CVSS 3.1
AVNACLPRNUIRSUCHIHAH
EPSS
2.65%
85.5th percentile
Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.
Affected
9 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| debian | libass | < libass 1:0.15.0-1 (bookworm) | libass 1:0.15.0-1 (bookworm) |
| libass_project | libass | < 0.15.0 | 0.15.0 |
| libass_project | libass | >= 0 < 1:0.15.0-1 | 1:0.15.0-1 |
| libass_project | libass | >= 0 < 1:0.15.0-1 | 1:0.15.0-1 |
| libass_project | libass | >= 0 < 1:0.15.0-1 | 1:0.15.0-1 |
| libass_project | libass | >= 0 < 1:0.15.0-1 | 1:0.15.0-1 |
| libass_project | libass | >= 0 < 0.10.1-3ubuntu1+esm1 | 0.10.1-3ubuntu1+esm1 |
| libass_project | libass | >= 0 < 0.13.1-1ubuntu0.1~esm2 | 0.13.1-1ubuntu0.1~esm2 |
| ubuntu | libass | — | — |
CVSS provenance
nvdv3.18.8HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
nvdv2.06.8MEDIUMAV:N/AC:M/Au:N/C:P/I:P/A:P
osv8.8HIGH
vendor_debian8.8HIGH
vendor_ubuntu8.8HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
GHSA-qrhf-wgfc-f8cx: Stack overflow in the parse_tag function in libass/ass_parse
ghsa_unreviewed·2022-05-24
CVE-2020-24994 [HIGH] CWE-787 GHSA-qrhf-wgfc-f8cx: Stack overflow in the parse_tag function in libass/ass_parse
Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.14.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.
OSV
libass vulnerabilities
osv·2022-05-04·CVSS 7.5
CVE-2016-7970 [HIGH] libass vulnerabilities
libass vulnerabilities
It was discovered that LibASS incorrectly handled certain ASS files. A remote
attacker could possibly use this issue to cause a denial of service. One of
the issues, CVE-2016-7970, only affected Ubuntu 16.04 ESM.
(CVE-2016-7969, CVE-2016-7970, CVE-2016-7972)
It was discovered that LibASS incorrectly handled parsing operations for
specific nested character strings. An attacker could possibly use this issue
to cause a denial of service. This issue was only fixed in Ubuntu 16.04 LTS.
(CVE-2020-24994)
OSV
CVE-2020-24994: Stack overflow in the parse_tag function in libass/ass_parse
osv·2021-03-23·CVSS 8.8
CVE-2020-24994 [HIGH] CVE-2020-24994: Stack overflow in the parse_tag function in libass/ass_parse
Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.
Ubuntu
libass vulnerabilities
vendor_ubuntu·2026-09-24·CVSS 8.8
CVE-2020-26682 [HIGH] libass vulnerabilities
Title: libass vulnerabilities
Summary: Several security issues were fixed in libass.
It was discovered that libass incorrectly handled parsing operations for
specific nested character strings. An attacker could use this issue to
cause libass to crash, resulting in a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 14.04 LTS,
Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS.
(CVE-2020-24994)
It was discovered that libass incorrectly handled certain outline
processing operations. An attacker could use this issue to cause libass
to crash, resulting in a denial of service. This issue only affected
Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-26682)
It was discovered that libass incorrectly handled certain ASS subtitle
files when measuring wr
Ubuntu
LibASS vulnerabilities
vendor_ubuntu·2022-05-04·CVSS 7.5
CVE-2016-7970 [HIGH] LibASS vulnerabilities
Title: LibASS vulnerabilities
Summary: Several security issues were fixed in LibASS.
It was discovered that LibASS incorrectly handled certain ASS files. A remote
attacker could possibly use this issue to cause a denial of service. One of
the issues, CVE-2016-7970, only affected Ubuntu 16.04 ESM.
(CVE-2016-7969, CVE-2016-7970, CVE-2016-7972)
It was discovered that LibASS incorrectly handled parsing operations for
specific nested character strings. An attacker could possibly use this issue
to cause a denial of service. This issue was only fixed in Ubuntu 16.04 LTS.
(CVE-2020-24994)
Instructions: In general, a standard system update will make all the necessary changes.
Debian
CVE-2020-24994: libass - Stack overflow in the parse_tag function in libass/ass_parse.c in libass before ...
vendor_debian·2020·CVSS 8.8
CVE-2020-24994 [HIGH] CVE-2020-24994: libass - Stack overflow in the parse_tag function in libass/ass_parse.c in libass before ...
Stack overflow in the parse_tag function in libass/ass_parse.c in libass before 0.15.0 allows remote attackers to cause a denial of service or remote code execution via a crafted file.
Scope: local
bookworm: resolved (fixed in 1:0.15.0-1)
bullseye: resolved (fixed in 1:0.15.0-1)
forky: resolved (fixed in 1:0.15.0-1)
sid: resolved (fixed in 1:0.15.0-1)
trixie: resolved (fixed in 1:0.15.0-1)
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
https://github.com/libass/libass/commit/6835731c2fe4164a0c50bc91d12c43b2a2b4ehttps://github.com/libass/libass/issues/422https://github.com/libass/libass/issues/422#issuecomment-806002919https://github.com/libass/libass/issues/423https://github.com/libass/libass/commit/6835731c2fe4164a0c50bc91d12c43b2a2b4ehttps://github.com/libass/libass/issues/422https://github.com/libass/libass/issues/422#issuecomment-806002919https://github.com/libass/libass/issues/423
2021-03-23
Published