cbcvebase.
CVE-2020-25698
published 2020-11-19

CVE-2020-25698: Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them…

PriorityP342high7.5CVSS 3.1
AVNACLPRNUINSUCNIHAN
EPSS
1.92%
79.8th percentile
Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.

Affected

15 ranges
VendorProductVersion rangeFixed in
fedoraprojectfedora——
fedoraprojectfedora——
moodlemoodle——
moodlemoodle——
moodlemoodle——
moodlemoodle——
moodlemoodle——
moodlemoodle>= 3.5 < 3.5.153.5.15
moodlemoodle3.5.0 – 3.5.14—
moodlemoodle>= 3.7.0 < 3.7.93.7.9
moodlemoodle3.7.0 – 3.7.8—
moodlemoodle>= 3.8.0 < 3.8.63.8.6
moodlemoodle3.8.0 – 3.8.5—
moodlemoodle>= 3.9.0 < 3.9.33.9.3
moodlemoodle3.9.0 – 3.9.2—

CVSS provenance

nvdv3.17.5HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
nvdv2.05.0MEDIUMAV:N/AC:L/Au:N/C:N/I:P/A:N
osv7.5HIGH
Stop checking back — get the weekly exploitation signal.

Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.