cbcvebase.
CVE-2021-22192
published 2021-03-24

CVE-2021-22192: An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.2 allowing unauthorized authenticated users to execute arbitrary code on…

PriorityP261high8.8CVSS 3.1
AVNACLPRLUINSUCHIHAH
EPSS
13.11%
96.3th percentile
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.2 allowing unauthorized authenticated users to execute arbitrary code on the server.

Affected

9 ranges
VendorProductVersion rangeFixed in
debiangitlab< gitlab 15.10.8+ds1-2 (sid)gitlab 15.10.8+ds1-2 (sid)
gitlabgitlab——
gitlabgitlab——
gitlabgitlab——
gitlabgitlab——
gitlabgitlab>= 13.2.0 < 13.7.913.7.9
gitlabgitlab>= 13.8.0 < 13.8.613.8.6
gitlabgitlab>= 13.9.0 < 13.9.413.9.4
gitlabgitlab_ce——

Detection & IOCsextracted from sources · hover to see the quote

  • ·Vulnerability affects GitLab CE/EE starting from version 13.2; fixed in Debian sid package version 15.10.8+ds1-2. No specific exploit payloads, hashes, or network indicators were present in the provided sources. ↗
  • ·Scope of exploitation is listed as local in the Debian security tracker, meaning the attack vector requires authenticated access to the GitLab instance rather than remote unauthenticated exploitation. ↗

CVSS provenance

nvdv3.18.8HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
nvdv2.06.5MEDIUMAV:N/AC:L/Au:S/C:P/I:P/A:P
osv8.8HIGH
vendor_debian9.9CRITICAL
Stop checking back — get the weekly exploitation signal.

Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.