CVE-2022-43705
published 2022-11-27CVE-2022-43705: In Botan before 2.19.3, it is possible to forge OCSP responses due to a certificate verification error. This issue was introduced in Botan 1.11.34 (November…
PriorityP340critical9.1CVSS 3.1
AVNACLPRNUINSUCHIHAN
EPSS
0.45%
38.9th percentile
In Botan before 2.19.3, it is possible to forge OCSP responses due to a certificate verification error. This issue was introduced in Botan 1.11.34 (November 2016).
Affected
4 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| botan_project | botan | >= 0 < 2.19.3+dfsg-1 | 2.19.3+dfsg-1 |
| botan_project | botan | >= 0 < 2.19.3+dfsg-1 | 2.19.3+dfsg-1 |
| botan_project | botan | >= 1.11.34 < 2.19.3 | 2.19.3 |
| debian | botan | < botan 2.19.3+dfsg-1 (bookworm) | botan 2.19.3+dfsg-1 (bookworm) |
CVSS provenance
nvdv3.19.1CRITICALCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
osv9.1CRITICAL
vendor_debian9.1CRITICAL
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Botan up to 2.19.2 OCSP Response certificate validation (GHSA-4v9w-qvcq-6q7w / EUVD-2022-46687)
vuldb·2026-09-12·CVSS 9.1
CVE-2022-43705 [CRITICAL] Botan up to 2.19.2 OCSP Response certificate validation (GHSA-4v9w-qvcq-6q7w / EUVD-2022-46687)
A vulnerability was found in Botan up to 2.19.2. It has been classified as critical. The affected element is an unknown function of the component OCSP Response Handler. This manipulation causes improper certificate validation.
The identification of this vulnerability is CVE-2022-43705. The attack needs to be done within the local network. There is no exploit available.
Upgrading the affected component is recommended.
OSV
CVE-2022-43705: In Botan before 2
osv·2022-11-27·CVSS 9.1
CVE-2022-43705 [CRITICAL] CVE-2022-43705: In Botan before 2
In Botan before 2.19.3, it is possible to forge OCSP responses due to a certificate verification error. This issue was introduced in Botan 1.11.34 (November 2016).
Debian
CVE-2022-43705: botan - In Botan before 2.19.3, it is possible to forge OCSP responses due to a certific...
vendor_debian·2022·CVSS 9.1
CVE-2022-43705 [CRITICAL] CVE-2022-43705: botan - In Botan before 2.19.3, it is possible to forge OCSP responses due to a certific...
In Botan before 2.19.3, it is possible to forge OCSP responses due to a certificate verification error. This issue was introduced in Botan 1.11.34 (November 2016).
Scope: local
bookworm: resolved (fixed in 2.19.3+dfsg-1)
bullseye: open
trixie: resolved (fixed in 2.19.3+dfsg-1)
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2022-11-27
Published