CVE-2024-52867
published 2024-11-17CVE-2024-52867: guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for…
PriorityP341high8.1CVSS 3.1
AVLACHPRNUINSCCHIHAH
EPSS
0.23%
13.0th percentile
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
Affected
3 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| debian | guix | < guix 1.2.0-4+deb11u3 (bullseye) | guix 1.2.0-4+deb11u3 (bullseye) |
| gnu | guix | >= 0 < 1.2.0-4+deb11u3 | 1.2.0-4+deb11u3 |
| ubuntu | guix | — | — |
CVSS provenance
nvdv3.18.1HIGHCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
osv8.1HIGH
vendor_debian8.1HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
GHSA-9h8f-hjmp-pwxx: guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (
ghsa_unreviewed·2024-11-17
CVE-2024-52867 [HIGH] CWE-276 GHSA-9h8f-hjmp-pwxx: guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
OSV
CVE-2024-52867: guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (
osv·2024-11-17·CVSS 8.1
CVE-2024-52867 [HIGH] CVE-2024-52867: guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
Ubuntu
GNU Guix vulnerability
vendor_ubuntu·2026-09-16
CVE-2024-52867 GNU Guix vulnerability
Title: GNU Guix vulnerability
Summary: GNU Guix could be made to run programs as an administrator.
It was discovered that GNU Guix incorrectly made build outputs accessible
to local users before their file metadata was finalized. A local attacker
could possibly use this issue to gain elevated privileges.
Instructions: After a standard system update you need to restart guix-daemon to make all
the necessary changes.
Debian
CVE-2024-52867: guix - guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build...
vendor_debian·2024·CVSS 8.1
CVE-2024-52867 [HIGH] CVE-2024-52867: guix - guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build...
guix-daemon in GNU Guix before 5ab3c4c allows privilege escalation because build outputs are accessible by local users before file metadata concerns (e.g., for setuid and setgid programs) are properly addressed. The vulnerability can be remediated within the product via certain pull, reconfigure, and restart actions. Both 5ab3c4c and 5582241 are needed to resolve the vulnerability.
Scope: local
bullseye: resolved (fixed in 1.2.0-4+deb11u3)
sid: resolved (fixed in 1.4.0-8)
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
https://git.savannah.gnu.org/cgit/guix.git/commit/?id=558224140dab669cabdaebabff18504a066c48d4https://git.savannah.gnu.org/cgit/guix.git/commit/?id=5ab3c4c1e43ebb637551223791db0ea3519986e1https://guix.gnu.org/en/blog/2024/build-user-takeover-vulnerability/https://lists.debian.org/debian-lts-announce/2024/11/msg00016.html
2024-11-17
Published