CVE-2025-55017
published 2026-06-26CVE-2025-55017: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 2.0.0…
PriorityP356critical9.1CVSS 3.1
AVNACLPRNUINSUCHIHAN
EPSS
0.54%
44.5th percentile
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6.
Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
Affected
2 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| apache_software_foundation | apache_iotdb | >= 1.0.0 < 1.3.6 | 1.3.6 |
| apache_software_foundation | apache_iotdb | >= 2.0.0 < 2.0.6 | 2.0.6 |
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Apache IoTDB up to 1.3.5/2.0.5 path traversal
vuldb·2026-09-30·CVSS 9.1
CVE-2025-55017 [CRITICAL] Apache IoTDB up to 1.3.5/2.0.5 path traversal
A vulnerability classified as critical was found in Apache IoTDB up to 1.3.5/2.0.5. Affected by this issue is some unknown functionality. Such manipulation leads to path traversal.
This vulnerability is referenced as CVE-2025-55017. It is possible to launch the attack remotely. No exploit is available.
Upgrading the affected component is advised.
GHSA
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
ghsa_unreviewed·2026-06-26
CVE-2025-55017 [CRITICAL] CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 2.0.0 before 2.0.6, from 1.0.0 before 1.3.6.
Users are recommended to upgrade to version 1.3.6 and 2.0.6, which fixes the issue.
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2026-06-26
Published