CVE-2025-64152
published 2026-06-26CVE-2025-64152: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB. This issue affects Apache IoTDB: from 1.0.0…
PriorityP356critical9.1CVSS 3.1
AVNACLPRNUINSUCHIHAN
EPSS
0.54%
45.0th percentile
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.6 and 2.0.7, which fixes the issue.
Affected
2 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| apache_software_foundation | apache_iotdb | >= 1.0.0 < 1.3.6 | 1.3.6 |
| apache_software_foundation | apache_iotdb | >= 2.0.0 < 2.0.7 | 2.0.7 |
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Apache IoTDB up to 1.3.5/2.0.6 path traversal
vuldb·2026-09-30·CVSS 9.1
CVE-2025-64152 [CRITICAL] Apache IoTDB up to 1.3.5/2.0.6 path traversal
A vulnerability, which was classified as critical, has been found in Apache IoTDB up to 1.3.5/2.0.6. This affects an unknown part. Performing a manipulation results in path traversal.
This vulnerability is identified as CVE-2025-64152. The attack can be initiated remotely. There is not any exploit available.
It is advisable to upgrade the affected component.
GHSA
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
ghsa_unreviewed·2026-06-26
CVE-2025-64152 [CRITICAL] CWE-22 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache IoTDB.
This issue affects Apache IoTDB: from 1.0.0 before 1.3.6, from 2.0.0 before 2.0.7.
Users are recommended to upgrade to version 1.3.6 and 2.0.7, which fixes the issue.
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2026-06-26
Published