CVE-2026-106443
published 2026-10-06CVE-2026-106443: WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img…
PriorityP260high8.8CVSS 3.1
AVNACLPRLUINSUCHIHAH
EPSS
0.69%
52.3th percentile
WeasyPrint helps web developers to create PDF documents. Prior to 70.0, the image-loading path in weasyprint/images.py passes fetched image bytes from HTML img URLs, CSS image values, SVG image references, and data URIs to Pillow's generic image dispatcher without excluding EPS or PostScript formats. On hosts with Ghostscript installed, Pillow EpsImagePlugin invokes the interpreter for attacker-controlled PostScript, which can produce interpreter-permitted effects and can lead to remote code execution when the installed Ghostscript version has a usable sandbox bypass. Hosts without Ghostscript do not reach this rasterization path. This issue is fixed in version 70.0.
Affected
3 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| ansible-automation-platform | automation-dashboard-rhel9 | — | — |
| kozea | weasyprint | < 70.0 | 70.0 |
| kozea | weasyprint | >= 0 < 70.0 | 70.0 |
CVSS provenance
nvdv3.18.8HIGHCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
vendor_redhat8.8HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
weasyprint: WeasyPrint: Arbitrary code execution via unsafe PostScript image processing
vendor_redhat·2026-10-06·CVSS 8.8
CVE-2026-106443 [HIGH] CWE-94 weasyprint: WeasyPrint: Arbitrary code execution via unsafe PostScript image processing
weasyprint: WeasyPrint: Arbitrary code execution via unsafe PostScript image processing
A flaw was found in WeasyPrint. When processing documents with external image references, the image loading mechanism passes untrusted image data to the underlying image library without restricting unsafe formats such as Encapsulated PostScript (EPS). A remote attacker could provide a crafted document referencing malicious PostScript content to trigger Ghostscript interpretation. On systems with Ghostscript installed, this flaw can lead to arbitrary code execution.
Package: ansible-automation-platform/automation-dashboard-rhel9 (Red Hat Ansible Automation Platform 2) - Affected
GHSA
WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
ghsa·2026-10-07
CVE-2026-106443 [HIGH] CWE-20 WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
WeasyPrint: EPS images reach the Ghostscript interpreter resulting in RCE
### Summary
This was found during a pentest, funded by the NLNnet foundation, conducted by Stefan Vink from Radically Open Security and the only High issue found.
WeasyPrint passes fetched image bytes directly to Pillow's generic format dispatcher without restricting the input format. When Ghostscript is installed on the host, Pillow's EpsImagePlugin invokes it to rasterize attacker-controlled EPS/PS input. Any content that can supply an image to WeasyPrint (an URL, CSS image value, SVG image reference, or data URI) can therefore drive untrusted PostScript into an external interpreter. On hosts running a Ghostscript version with a known -dSAFER bypass, this yields remote code execution.
### Details
The image pip
No detection rules found.
No public exploits indexed.
2026-10-06
Published