CVE-2026-108574
published 2026-10-11CVE-2026-108574: A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file…
PriorityP425medium4.3CVSS 3.1
AVNACLPRLUINSUCLINAN
EPSS
0.24%
14.1th percentile
A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 1.96.0 can resolve this issue. This patch is called 722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b. The affected component should be upgraded.
Affected
104 ranges· showing 25
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| ansible-automation-platform-26 | lightspeed-chatbot-rhel9 | — | — |
| ansible-automation-platform-27 | lightspeed-chatbot-rhel9 | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
| berriai | litellm | — | — |
CVSS provenance
nvdv3.14.3MEDIUMCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
nvdv4.02.1LOWCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvdv2.04.0MEDIUMAV:N/AC:L/Au:S/C:P/I:N/A:N
vendor_redhat4.3MEDIUM
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
litellm: litellm: Authorization bypass via session identifier manipulation
vendor_redhat·2026-10-11·CVSS 4.3
CVE-2026-108574 [MEDIUM] CWE-639 litellm: litellm: Authorization bypass via session identifier manipulation
litellm: litellm: Authorization bypass via session identifier manipulation
A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 1.96.0 can resolve this issue. This patch is called 722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b. The affected component should be upgraded.
A flaw was found in LiteLLM. A remote attacker can bypass authorization controls by manipulating the session identifier (session_id) parameter in the spend trac
VulDB
BerriAI LiteLLM up to 1.95.0 Spend Tracking spend_management_endpoints.py ui_view_session_spend_logs session_id authorization (EUVD-2026-96884 / WID-SEC-2026-3864)
vuldb·2026-10-13·CVSS 4.3
CVE-2026-108574 [MEDIUM] BerriAI LiteLLM up to 1.95.0 Spend Tracking spend_management_endpoints.py ui_view_session_spend_logs session_id authorization (EUVD-2026-96884 / WID-SEC-2026-3864)
A vulnerability labeled as problematic has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass.
This vulnerability is registered as CVE-2026-108574. It is possible to launch the attack remotely. Furthermore, an exploit is available.
The affected component should be upgraded.
GHSA
A flaw has been found in BerriAI LiteLLM up to 1.95.0.
ghsa_unreviewed·2026-10-11
CVE-2026-108574 [LOW] CWE-285 A flaw has been found in BerriAI LiteLLM up to 1.95.0.
A flaw has been found in BerriAI LiteLLM up to 1.95.0. Affected by this issue is the function ui_view_session_spend_logs of the file litellm/proxy/spend_tracking/spend_management_endpoints.py of the component Spend Tracking. Executing a manipulation of the argument session_id can lead to authorization bypass. It is possible to launch the attack remotely. The exploit has been published and may be used. Upgrading to version 1.96.0 can resolve this issue. This patch is called 722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308b. The affected component should be upgraded.
No detection rules found.
No public exploits indexed.
https://github.com/BerriAI/litellm/https://github.com/BerriAI/litellm/commit/722d9ffa4f6c5ae15702ab9ab2c5f6bf1688308bhttps://github.com/BerriAI/litellm/releases/tag/v1.96.0https://vuldb.com/cve/CVE-2026-108574https://vuldb.com/submit/955441https://vuldb.com/vuln/416231https://vuldb.com/vuln/416231/cti
2026-10-11
Published