CVE-2026-25688
published 2026-06-09CVE-2026-25688: Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer. This issue affects Apache Answer: through 2.0.0. AI-generated response content…
PriorityP428medium6.1CVSS 3.1
AVNACLPRNUIRSCCLILAN
EPSS
0.57%
46.7th percentile
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer.
This issue affects Apache Answer: through 2.0.0.
AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed.
Users are recommended to upgrade to version 2.0.1, which fixes the issue.
Affected
3 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| apache | answer | < 2.0.1 | 2.0.1 |
| apache_software_foundation | apache_answer | <= 2.0.0 | — |
| github.com | apache_incubator-answer | >= 0 < 1.7.2-0.20260525024654-2746bf5b455f | 1.7.2-0.20260525024654-2746bf5b455f |
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer.
ghsa_unreviewed·2026-06-09
CVE-2026-25688 [MEDIUM] CWE-87 Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer.
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer.
This issue affects Apache Answer: through 2.0.0.
AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed.
Users are recommended to upgrade to version 2.0.1, which fixes the issue.
GHSA
Apache Answer has an Improper Neutralization of Alternate XSS Syntax vulnerability
ghsa·2026-06-09
CVE-2026-25688 [MEDIUM] CWE-87 Apache Answer has an Improper Neutralization of Alternate XSS Syntax vulnerability
Apache Answer has an Improper Neutralization of Alternate XSS Syntax vulnerability
Improper Neutralization of Alternate XSS Syntax vulnerability in Apache Answer.
This issue affects Apache Answer: through 2.0.0.
AI-generated response content was rendered in the browser without proper sanitization, allowing malicious scripts to be executed when the content was viewed.
Users are recommended to upgrade to version 2.0.1, which fixes the issue.
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2026-06-09
Published