CVE-2026-26080
published 2026-07-20CVE-2026-26080: HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also…
PriorityP416low3.7CVSS 3.1
AVNACHPRNUINSUCNINAL
EPSS
0.55%
45.5th percentile
HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.
Affected
26 ranges· showing 25
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| debian | haproxy | < haproxy 3.2.11-2 (forky) | haproxy 3.2.11-2 (forky) |
| haproxy | aloha | >= 17.0.0 < 17.0.18 | 17.0.18 |
| haproxy | aloha | >= 17.5.0 < 17.5.16 | 17.5.16 |
| haproxy | haproxy | — | — |
| haproxy | haproxy | >= 3.2 < 3.2.12 | 3.2.12 |
| haproxy | haproxy | >= 3.3 < 3.3.3 | 3.3.3 |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
| haproxy | haproxy_enterprise | — | — |
CVSS provenance
nvdv3.13.7LOWCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
vendor_redhat3.7LOW
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
HAProxy ALOHA/Community Edition/Enterprise up to 3.2.11/3.3.2 varint infinite loop
vuldb·2026-08-25·CVSS 3.7
CVE-2026-26080 [LOW] HAProxy ALOHA/Community Edition/Enterprise up to 3.2.11/3.3.2 varint infinite loop
A vulnerability categorized as critical has been discovered in HAProxy ALOHA, Community Edition and Enterprise up to 3.2.11/3.3.2. The impacted element is an unknown function of the component varint. The manipulation results in infinite loop.
This vulnerability is known as CVE-2026-26080. It is possible to launch the attack remotely. No exploit is available.
It is advisable to upgrade the affected component.
GHSA
HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled.
ghsa_unreviewed·2026-07-20
CVE-2026-26080 [LOW] CWE-252 HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled.
HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.
Red Hat
haproxy: HAProxy: Denial of Service due to mishandled varint
vendor_redhat·2026-07-20·CVSS 3.7
CVE-2026-26080 [LOW] CWE-835 haproxy: HAProxy: Denial of Service due to mishandled varint
haproxy: HAProxy: Denial of Service due to mishandled varint
HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.
A flaw was found in HAProxy. An attacker can exploit a vulnerability where the software mishandles varint (variable-length integer encoding). This can cause HAProxy to enter an infinite loop or crash, leading to a denial of service for affected systems.
Package: haproxy (Red Hat Hardened Images) - Affected
Debian
CVE-2026-26080: haproxy
vendor_debian·2026
CVE-2026-26080 [LOW] CVE-2026-26080: haproxy
bookworm: resolved
bullseye: resolved
forky: resolved (fixed in 3.2.11-2)
sid: resolved (fixed in 3.2.11-2)
trixie: resolved
No detection rules found.
No public exploits indexed.
Wiz
CVE-2026-26081 Impact, Exploitability, and Mitigation Steps | Wiz
blogs_wiz·CVSS 7.5
CVE-2026-26081 [HIGH] CVE-2026-26081 Impact, Exploitability, and Mitigation Steps | Wiz
## CVE-2026-26081 :
HAProxy vulnerability analysis and mitigation
crash via INITIAL packet for the NEW_TOKEN format
Source : NVD
Published February 12, 2026
CNA Score N/A
Affected Technologies
HAProxy
Has Public Exploit No
Has CISA KEV Exploit No
CISA KEV Release Date N/A
CISA KEV Due Date N/A
Exploitation Probability Percentile (EPSS) N/A
Exploitation Probability (EPSS) N/A
Affected packages and libraries
haproxy
Sources
NVD
Debian 13, 14 Has Fix Added at: Feb 12, 2026
Ubuntu 25.10 Severity MEDIUM Has Fix Added at: Feb 15, 2026
## Get a CVE risk assessment
Get a prioritized view of CVEs in your cloud—so you can focus on what's exploitable, not just what's listed.
## Related HAProxy vulnerabilities:
CVE ID
Severity
Score
Technologies
Component name
CISA KEV
Wiz
CVE-2026-26080 Impact, Exploitability, and Mitigation Steps | Wiz
blogs_wiz·CVSS 7.5
CVE-2026-26080 [HIGH] CVE-2026-26080 Impact, Exploitability, and Mitigation Steps | Wiz
## CVE-2026-26080 :
HAProxy vulnerability analysis and mitigation
crash in parsing frame type
Source : NVD
Published February 12, 2026
CNA Score N/A
Affected Technologies
HAProxy
Has Public Exploit No
Has CISA KEV Exploit No
CISA KEV Release Date N/A
CISA KEV Due Date N/A
Exploitation Probability Percentile (EPSS) N/A
Exploitation Probability (EPSS) N/A
Affected packages and libraries
haproxy
Sources
NVD
Debian 14 Has Fix Added at: Feb 12, 2026
## Get a CVE risk assessment
Get a prioritized view of CVEs in your cloud—so you can focus on what's exploitable, not just what's listed.
## Related HAProxy vulnerabilities:
CVE ID
Severity
Score
Technologies
Component name
CISA KEV exploit
Has fix
Published date
CVE-2025-11230
HIGH
7.5
HAProxy
haproxy-2.4
No
Bugzilla
CVE-2026-26080 haproxy: HAProxy: Denial of Service due to mishandled varint
bugzilla·2026-07-20·CVSS 3.7
CVE-2026-26080 [LOW] CVE-2026-26080 haproxy: HAProxy: Denial of Service due to mishandled varint
CVE-2026-26080 haproxy: HAProxy: Denial of Service due to mishandled varint
HAProxy Community Edition 3.2.x through 3.3.x before 3.3.3 can enter a loop or crash because varint is mishandled. HAProxy Enterprise and ALOHA are also affected.
2026-07-20
Published