CVE-2026-67404
published 2026-09-23CVE-2026-67404: RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls…
PriorityP347high7.4CVSS 3.1
AVNACHPRNUINSUCHIHAN
EPSS
0.20%
9.4th percentile
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Affected
9 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| broadcom | rabbitmq_server | >= 3.13.0 < 3.13.15 | 3.13.15 |
| broadcom | rabbitmq_server | >= 4.0.0 < 4.0.20 | 4.0.20 |
| broadcom | rabbitmq_server | >= 4.1.0 < 4.1.11 | 4.1.11 |
| broadcom | rabbitmq_server | >= 4.2.0 < 4.2.6 | 4.2.6 |
| rabbitmq | rabbitmq-server | — | — |
| rabbitmq | rabbitmq-server | — | — |
| rabbitmq | rabbitmq-server | — | — |
| rabbitmq | rabbitmq-server | — | — |
| ubuntu | rabbitmq-server | — | — |
CVSS provenance
nvdv3.17.4HIGHCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
nvdv4.09.2CRITICALCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
vendor_redhat9.2CRITICAL
vendor_ubuntu7.6HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Ubuntu
RabbitMQ Server vulnerabilities
vendor_ubuntu·2026-10-15·CVSS 7.6
CVE-2026-67404 [HIGH] RabbitMQ Server vulnerabilities
Title: RabbitMQ Server vulnerabilities
Summary: Several security issues were fixed in RabbitMQ Server.
It was discovered that RabbitMQ Server incorrectly handled CORS wildcard
origin configuration. An attacker could possibly use this issue to cause
a cross-site request forgery attack. This issue only affected Ubuntu 18.04
LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04
LTS. (CVE-2026-66070)
It was discovered that RabbitMQ Server incorrectly handled TLS
peer-certificate DNs in the management UI. An attacker could possibly use
this issue to cause a cross-site scripting attack. (CVE-2026-66077)
It was discovered that RabbitMQ Server incorrectly handled AMQP 1.0 arrays
with zero-width element constructors. An attacker could possibly use this
issue to cause a den
Red Hat
rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
vendor_redhat·2026-09-23·CVSS 9.2
CVE-2026-67404 [CRITICAL] CWE-295 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
A flaw was found in rabbitmq-server. When the OAuth2 plugin fetches JWKS and n
VulDB
RabbitMQ prior 3.13.15/4.0.20/4.1.11/4.2.6/4.3.0 SSL Options ssl_options channel accessible
vuldb·2026-09-23·CVSS 9.2
CVE-2026-67404 [CRITICAL] RabbitMQ prior 3.13.15/4.0.20/4.1.11/4.2.6/4.3.0 SSL Options ssl_options channel accessible
A vulnerability was found in RabbitMQ and classified as critical. This affects the function ssl_options of the component SSL Options. The manipulation results in channel accessible by non-endpoint.
This vulnerability is cataloged as CVE-2026-67404. The attack may be launched remotely. There is no exploit available.
It is suggested to upgrade the affected component.
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch [fedora-all]
bugzilla·2026-10-08·CVSS 9.2
CVE-2026-67404 [CRITICAL] CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch [fedora-all]
CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for e
Bugzilla
CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
bugzilla·2026-09-23·CVSS 9.2
CVE-2026-67404 [CRITICAL] CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
CVE-2026-67404 rabbitmq-server: rabbitmq-server: OAuth2 silent verify_none fallback for JWKS fetch
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, When no CA bundle is available, ssl_options/1 falls back to [{verify, verify_none}] with no warning. An attacker in a man-in-the-middle position can forge the JWKS response, which leads the broker to accept arbitrary JWTs. Preconditions include The OAuth2 plugin must be in use with no cacertfile configured and the OS CA bundle empty or unreadable (for example, in a minimal container), and the attacker must hold a network man-in-the-middle position.. This issue is fixed in versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0.
Discussion:
CVSS Justifications
AV:N -- JWKS fetched over the
2026-09-23
Published