cbcvebase.
CVE-2026-7210
published 2026-05-11

CVE-2026-7210: `xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger…

PriorityP344high7.5CVSS 3.1
AVNACLPRNUINSUCNINAH
EPSS
0.67%
51.8th percentile
`xml.parsers.expat` and `xml.etree.ElementTree` use insufficient entropy for Expat hash-flooding protection, which allows a crafted XML document to trigger hash flooding.\r\n\r\nFully mitigating this vulnerability requires both updating libexpat to 2.8.0 or later and applying this patch.

Affected

31 ranges· showing 25
VendorProductVersion rangeFixed in
debianpython3.14——
debianpython3.9——
exploit-intelligence-tech-previewvulnerability-analysis-rhel9——
pythonpython< 3.13.143.13.14
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython——
pythonpython>= 3.14.0 < 3.14.63.14.6
python36_3.6python36——
python_software_foundationcpython< 3.10.223.10.22
python_software_foundationcpython>= 3.11.0 < 3.11.163.11.16
python_software_foundationcpython>= 3.12.0 < 3.12.143.12.14
python_software_foundationcpython>= 3.13.0 < 3.13.143.13.14
python_software_foundationcpython>= 3.14.0 < 3.14.63.14.6
python_software_foundationcpython>= 3.15.0a1 < 3.15.0b23.15.0b2
rhelai3bootc-aws-cuda-rhel9——
rhelai3bootc-azure-cuda-rhel9——
rhelai3bootc-azure-rocm-rhel9——

CVSS provenance

nvdv3.17.5HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
nvdv4.06.3MEDIUMCVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
vendor_redhat6.3MEDIUM
Stop checking back — get the weekly exploitation signal.

Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.