CVE-2026-73417
published 2026-08-13CVE-2026-73417: jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 3.3.0 until 4.5.10 and…
PriorityP351high8.6CVSS 4.0
AVNACLATNPRNUIAVCHVIHVALSCNSINSALEXCRXIRXARXMAVXMACXMATXMPRXMUIXMVCXMVIXMVAXMSCXMSIXMSAXSXAUXRXVXREXUX
EPSS
0.75%
54.4th percentile
jupyterlab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 3.3.0 until 4.5.10 and 4.6.2, JupyterLab allows notebook settings to be shared and applied through an overrides.json file using the Import button in the Settings Editor. In packages/notebook-extension/schema/tracker.json and packages/notebook-extension/src/index.ts, the sideBySideLeftMarginOverride and sideBySideRightMarginOverride settings are not properly validated before being inserted into style content, allowing a crafted settings file to contain instructions that execute as code instead of only changing display preferences. A user can import the malicious file, or an attacker with access to a shared settings location can plant an overrides.json that is applied automatically. The embedded code runs with the affected user's access and can read or modify notebooks and files and run code through the notebook server, including on a connected kernel. This issue is fixed in versions 4.5.10 and 4.6.2.
Affected
19 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| jupyterlab | jupyterlab | — | — |
| jupyterlab | jupyterlab | — | — |
| mta | mta-solution-server-rhel9 | — | — |
| rhoai | odh-feature-server-rhel9 | — | — |
| rhoai | odh-th06-cpu-torch210-py312-rhel9 | — | — |
| rhoai | odh-th06-cpu-torch291-py312-rhel9 | — | — |
| rhoai | odh-th06-cuda130-torch210-py312-rhel9 | — | — |
| rhoai | odh-th06-cuda130-torch291-py312-rhel9 | — | — |
| rhoai | odh-th06-rocm64-torch291-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-datascience-cpu-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-minimal-cpu-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-minimal-cuda-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-minimal-rocm-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-pytorch-cuda-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-pytorch-llmcompressor-cuda-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-pytorch-rocm-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-tensorflow-cuda-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-tensorflow-rocm-py312-rhel9 | — | — |
| rhoai | odh-workbench-jupyter-trustyai-cpu-py312-rhel9 | — | — |
CVSS provenance
nvdv4.08.6HIGHCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
vendor_redhat8.6HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Jupyter JupyterLab up to 4.5.9/4.6.1 Notebook Extension index.ts code injection
vuldb·2026-08-14·CVSS 8.6
CVE-2026-73417 [HIGH] Jupyter JupyterLab up to 4.5.9/4.6.1 Notebook Extension index.ts code injection
A vulnerability labeled as problematic has been found in Jupyter JupyterLab up to 4.5.9/4.6.1. Affected is an unknown function of the file packages/notebook-extension/src/index.ts of the component Notebook Extension. Executing a manipulation of the argument sideBySideLeftMarginOverride/sideBySideRightMarginOverride can lead to code injection.
This vulnerability appears as CVE-2026-73417. The attack may be performed from remote. There is no available exploit.
The affected component should be upgraded.
Red Hat
jupyterlab: JupyterLab: Cross-site scripting (XSS) allows arbitrary code execution
vendor_redhat·2026-08-13·CVSS 8.6
CVE-2026-73417 [HIGH] CWE-79 jupyterlab: JupyterLab: Cross-site scripting (XSS) allows arbitrary code execution
jupyterlab: JupyterLab: Cross-site scripting (XSS) allows arbitrary code execution
A flaw was found in JupyterLab. Improper validation of `sideBySideLeftMarginOverride` and `sideBySideRightMarginOverride` settings within the `overrides.json` file allows for cross-site scripting (XSS). An attacker can exploit this by convincing a user to import a specially crafted settings file, or by placing such a file in a shared settings location. Successful exploitation can lead to arbitrary code execution, enabling the attacker to read or modify notebooks and files, and run code through the notebook server.
Package: mta/mta-solution-server-rhel9 (Migration Toolkit for Applications 8) - Affected
Package: rhoai/odh-feature-server-rhel9 (Red Hat OpenShift AI (RHOAI)) - Affected
Package: rhoai/odh-th0
No detection rules found.
No public exploits indexed.
https://github.com/jupyterlab/jupyterlab/commit/9365f020baec5221deaf11535ed554c06637c999https://github.com/jupyterlab/jupyterlab/commit/be9303f5bcd5308eaeae953c5a3c903046682c2chttps://github.com/jupyterlab/jupyterlab/commit/f1beab4a2027af4719d6edc07d52d6cf5a39a432https://github.com/jupyterlab/jupyterlab/pull/19184https://github.com/jupyterlab/jupyterlab/pull/19185https://github.com/jupyterlab/jupyterlab/pull/19186https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.10https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.2https://github.com/jupyterlab/jupyterlab/releases/tag/v4.7.0a1https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-pppj-hq3g-57pj
2026-08-13
Published