CVE-2026-75880
published 2026-09-10CVE-2026-75880: An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery…
PriorityP337medium6.5CVSS 3.1
AVNACLPRLUINSUCNINAH
EPSS
0.65%
50.7th percentile
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
Affected
4 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| apache | artemis | >= 1.0.0 < 2.44.0 | 2.44.0 |
| apache | artemis | >= 2.50.0 < 2.57.0 | 2.57.0 |
| apache_software_foundation | apache_activemq_artemis | 1.0.0 – 2.44.0 | — |
| apache_software_foundation | apache_artemis | 2.50.0 – 2.56.0 | — |
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker threa
ghsa_unreviewed·2026-09-10
CVE-2026-75880 [MEDIUM] CWE-1333 An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker threa
An authenticated client could attach a consumer with a selector containing crafted wildcard usage that results in excessive evaluation during message delivery attempts, occupying a shared broker thread and leading to denial of service.
This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0.
Users are recommended to upgrade to version 2.57.0, which fixes this issue.
VulDB
Apache ActiveMQ Artemis Message selector denial of service
vuldb·2026-09-10
CVE-2026-75880 [LOW] Apache ActiveMQ Artemis Message selector denial of service
A vulnerability was found in Apache ActiveMQ Artemis and classified as problematic. This impacts an unknown function of the component Message selector. The manipulation results in denial of service.
This vulnerability is identified as CVE-2026-75880. The attack can be executed remotely. There is not any exploit available.
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2026-09-10
Published