CVE-2026-76879
published 2026-08-19CVE-2026-76879: C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
PriorityP335high7.5CVSS 3.1
AVNACLPRNUINSUCNINAH
EPSS
0.31%
22.8th percentile
C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.18 | 4.4.18 |
| wireshark | wireshark | >= 4.6.0 < 4.6.8 | 4.6.8 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.18 | 4.4.18 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.8 | 4.6.8 |
CVSS provenance
nvdv3.17.5HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
vendor_redhat7.5HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
wireshark: Wireshark: Denial of Service via C12.22 protocol dissector crash
vendor_redhat·2026-08-19·CVSS 7.5
CVE-2026-76879 [HIGH] CWE-617 wireshark: Wireshark: Denial of Service via C12.22 protocol dissector crash
wireshark: Wireshark: Denial of Service via C12.22 protocol dissector crash
C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
A flaw in Wireshark's C12.22 protocol dissector allows remote attackers to trigger a Denial of Service (DoS). By sending a specially crafted network packet or capture file, an attacker can crash the application, disrupting network analysis capabilities.
Statement: A denial of service flaw in Wireshark's C12.22 protocol dissector allows a remote attacker to crash the application via a crafted network packet, disrupting network analysis operations without requiring user interaction or privileges. RHEL 9 and older versions are not affected.
Mitigation: Avoid analyzing capture files or live traffic from untrusted sources.
GitLab
Stack-based Buffer Overflow in Wireshark
vendor_gitlab·2026-08-19·CVSS 7.5
CVE-2026-76879 [HIGH] CWE-121 Stack-based Buffer Overflow in Wireshark
Stack-based Buffer Overflow in Wireshark
C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.18 (affected)
Solution: Upgrade to version 4.6.8 or above
Credit: Aisle Research (Dmitrijs Trizna, Luigino Camastra, Ze Sheng (O2Lab & TAMU), Igor Morgenstern)
VulDB
Wireshark up to 4.4.17/4.6.7 Dissector input validation
vuldb·2026-08-20·CVSS 7.5
CVE-2026-76879 [HIGH] Wireshark up to 4.4.17/4.6.7 Dissector input validation
A vulnerability, which was classified as problematic, was found in Wireshark up to 4.4.17/4.6.7. Affected by this issue is some unknown functionality of the component Dissector. The manipulation results in improper input validation.
This vulnerability is known as CVE-2026-76879. It is possible to launch the attack remotely. No exploit is available.
You should upgrade the affected component.
GHSA
C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-08-20
CVE-2026-76879 [HIGH] CWE-121 C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
C12.22 protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
No detection rules found.
No public exploits indexed.
2026-08-19
Published