CVE-2026-76928
published 2026-08-19CVE-2026-76928: X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
PriorityP335high7.5CVSS 3.1
AVNACLPRNUINSUCNINAH
EPSS
0.32%
23.5th percentile
X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.18 | 4.4.18 |
| wireshark | wireshark | >= 4.6.0 < 4.6.8 | 4.6.8 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.18 | 4.4.18 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.8 | 4.6.8 |
CVSS provenance
nvdv3.17.5HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
vendor_redhat7.5HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Wireshark up to 4.4.17/4.6.7 Dissector resource consumption
vuldb·2026-08-20·CVSS 7.5
CVE-2026-76928 [HIGH] Wireshark up to 4.4.17/4.6.7 Dissector resource consumption
A vulnerability categorized as problematic has been discovered in Wireshark up to 4.4.17/4.6.7. Affected is an unknown function of the component Dissector. Such manipulation leads to resource consumption.
This vulnerability is referenced as CVE-2026-76928. It is possible to launch the attack remotely. No exploit is available.
It is advisable to upgrade the affected component.
GHSA
X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-08-20
CVE-2026-76928 [HIGH] CWE-476 X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
GitLab
NULL Pointer Dereference in Wireshark
vendor_gitlab·2026-08-19·CVSS 7.5
CVE-2026-76928 [HIGH] CWE-476 NULL Pointer Dereference in Wireshark
NULL Pointer Dereference in Wireshark
X.509IF protocol dissector crash in 4.6.0 to 4.6.7 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.18 (affected)
Solution: Upgrade to version 4.6.8 or above
Credit: Aisle Research (Dmitrijs Trizna, Luigino Camastra, Ze Sheng (O2Lab & TAMU), Igor Morgenstern)
Red Hat
wireshark: Wireshark: Denial of Service via X.509IF protocol dissector crash
vendor_redhat·2026-08-19·CVSS 7.5
CVE-2026-76928 [HIGH] CWE-825 wireshark: Wireshark: Denial of Service via X.509IF protocol dissector crash
wireshark: Wireshark: Denial of Service via X.509IF protocol dissector crash
A flaw was found in Wireshark. A remote attacker could exploit a NULL pointer dereference vulnerability in the X.509IF protocol dissector. This could lead to a denial of service, making the application unavailable to legitimate users.
Package: wireshark (Red Hat Enterprise Linux 10) - Under investigation
Package: wireshark (Red Hat Enterprise Linux 6) - Under investigation
Package: wireshark (Red Hat Enterprise Linux 7) - Under investigation
Package: wireshark (Red Hat Enterprise Linux 8) - Under investigation
Package: wireshark (Red Hat Enterprise Linux 9) - Under investigation
No detection rules found.
No public exploits indexed.
2026-08-19
Published