CVE-2026-8084
published 2026-05-07CVE-2026-8084: A vulnerability was determined in OSGeo gdal up to 3.13.0dev-4. This vulnerability affects the function memmove of the file frmts/hdf4/hdf-eos/SWapi.c of the…
PriorityP425medium5.5CVSS 3.1
AVLACLPRLUINSUCNINAH
EPSS
0.26%
18.2th percentile
A vulnerability was determined in OSGeo gdal up to 3.13.0dev-4. This vulnerability affects the function memmove of the file frmts/hdf4/hdf-eos/SWapi.c of the component HDF-EOS Grid File Handler. This manipulation causes out-of-bounds read. The attack is restricted to local execution. The exploit has been publicly disclosed and may be utilized. Upgrading to version 3.13.0RC1 is able to resolve this issue. Patch name: a791f70f8eaec540974ec989ca6fb00266b7646c. Upgrading the affected component is advised.
Affected
4 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| osgeo | gdal | <= 3.12.4 | — |
| osgeo | gdal | — | — |
| osgeo | gdal | — | — |
| ubuntu | gdal | — | — |
CVSS provenance
nvdv3.15.5MEDIUMCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
nvdv4.01.9LOWCVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
nvdv2.01.7LOWAV:L/AC:L/Au:S/C:N/I:N/A:P
vendor_ubuntu7.8HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Ubuntu
GDAL vulnerabilities
vendor_ubuntu·2026-09-24·CVSS 7.8
CVE-2026-8088 [HIGH] GDAL vulnerabilities
Title: GDAL vulnerabilities
Summary: Several security issues were fixed in GDAL.
It was discovered that GDAL incorrectly handled certain netCDF files. An
attacker could possibly use this issue to execute arbitrary code. This issue
only affected Ubuntu 22.04 LTS, Ubuntu 24.04 LTS, and Ubuntu 26.04 LTS.
(CVE-2026-49014)
It was discovered that GDAL incorrectly handled certain HDF-EOS files. An
attacker could possibly use this issue to cause a crash or execute arbitrary
code. (CVE-2026-8086, CVE-2026-8087, CVE-2026-8212, CVE-2026-8213)
It was discovered that GDAL incorrectly handled certain HDF-EOS file
metadata. An attacker could possibly use this issue to cause GDAL to crash,
resulting in a denial of service. (CVE-2026-8084, CVE-2026-8088)
Instructions: In general, a standard system upd
GHSA
GHSA-jmvp-7877-wr2f: A vulnerability was determined in OSGeo gdal up to 3
ghsa_unreviewed·2026-05-07
CVE-2026-8084 [LOW] CWE-119 GHSA-jmvp-7877-wr2f: A vulnerability was determined in OSGeo gdal up to 3
A vulnerability was determined in OSGeo gdal up to 3.13.0dev-4. This vulnerability affects the function memmove of the file frmts/hdf4/hdf-eos/SWapi.c of the component HDF-EOS Grid File Handler. This manipulation causes out-of-bounds read. The attack is restricted to local execution. The exploit has been publicly disclosed and may be utilized. Upgrading to version 3.13.0RC1 is able to resolve this issue. Patch name: a791f70f8eaec540974ec989ca6fb00266b7646c. Upgrading the affected component is advised.
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
https://github.com/OSGeo/gdal/https://github.com/OSGeo/gdal/commit/a791f70f8eaec540974ec989ca6fb00266b7646chttps://github.com/OSGeo/gdal/issues/14378https://github.com/OSGeo/gdal/releases/tag/v3.13.0RC1https://github.com/biniamf/pocs/blob/main/gdal_swfinfo_dimlist_oob-rwhttps://github.com/biniamf/pocs/tree/main/gdal_swfinfo_dimlist_oob-rwhttps://vuldb.com/submit/808034https://vuldb.com/vuln/361838https://vuldb.com/vuln/361838/cti
2026-05-07
Published