CVE-2026-81158
published 2026-09-02CVE-2026-81158: Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing. This issue affects Entity API versions: from 0.0.0 to 1.8.0.
PriorityP431medium5.3CVSS 3.1
AVNACLPRNUINSUCLINAN
EPSS
0.31%
24.2th percentile
Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing. This issue affects Entity API versions: from 0.0.0 to 1.8.0.
Affected
4 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| drupal | entity_api | — | — |
| drupal | entity_api | >= 0.0.0 < 1.8.0 | 1.8.0 |
| entity_api_project | entity_api | 7.x-1.0 – 7.x-1.11 | — |
| entity_api_project | entity_api | >= 8.x-0.1 < 8.x-1.8 | 8.x-1.8 |
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing.
ghsa_unreviewed·2026-09-02
CVE-2026-81158 [MEDIUM] CWE-863 Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing.
Incorrect Authorization vulnerability in Drupal Entity API allows Forceful Browsing. This issue affects Entity API versions: from 0.0.0 to 1.8.0.
Drupal
Entity API - Moderately critical - Information disclosure - SA-CONTRIB-2026-113
vendor_drupal·2026-08-26
CVE-2026-81158 [MEDIUM] Entity API - Moderately critical - Information disclosure - SA-CONTRIB-2026-113
Title: Entity API - Moderately critical - Information disclosure - SA-CONTRIB-2026-113
Vulnerability Type: Information disclosure
Description: The Entity API module extends the Drupal core entity API to provide a unified way to deal with entities and their properties. The module doesn't correctly apply access controls for JSON:API entity collection endpoints. This exposes an information disclosure vulnerability. This vulnerability is mitigated by the fact that the JSON:API module must be enabled in combination with the Entity API module.
Solution: Install the latest version: If you use the Entity API module, upgrade to Entity API 8.x-1.8 .
No detection rules found.
No public exploits indexed.
No writeups or analysis indexed.
2026-09-02
Published