CVE-2026-9112
published 2026-05-20CVE-2026-9112: Use after free in GPU in Google Chrome on Windows prior to 148.0.7778.179 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted…
PriorityP354high8.8CVSS 3.1
AVNACLPRNUIRSUCHIHAH
EPSS
0.40%
33.5th percentile
Use after free in GPU in Google Chrome on Windows prior to 148.0.7778.179 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
Affected
4 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| chrome | < 148.0.7778.179 | 148.0.7778.179 | |
| chrome | >= 148.0.7778.179 < 148.0.7778.179 | 148.0.7778.179 | |
| chrome_desktop | — | — | |
| paloalto | prisma_browser | — | — |
CVSS provenance
nvdv3.18.8HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
vendor_redhat8.8HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
jetty: Jetty: Improper Host header validation can lead to request routing issues
vendor_redhat·2026-07-14·CVSS 5.3
CVE-2026-6790 [MEDIUM] CWE-940 jetty: Jetty: Improper Host header validation can lead to request routing issues
jetty: Jetty: Improper Host header validation can lead to request routing issues
In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority (host and port) matches what provided in the Host header (if present).
This was not enforced in earlier HTTP RFC (for example, in RFC 2616), but it is in the latest RFC (9110 and 9112).
This mismatch can cause a number of problems that may be classified as vulnerabilities such as:
*
URI constructions (for example, for redirects -- this is typical for login pages)
*
Virtual host selection
*
Reverse proxying
*
Misleading logs
*
Etc.
Given that the latest RFCs require that request authority and Host header must match, Jetty should enforce this invariant.
A flaw was found in Eclipse Jetty. The server doe
Palo Alto
PAN-SA-2026-0008 Chromium: Monthly Vulnerability Update (June 2026)
vendor_paloalto·2026-06-10·CVSS 8.8
CVE-2026-8509 [HIGH] PAN-SA-2026-0008 Chromium: Monthly Vulnerability Update (June 2026)
PAN-SA-2026-0008 Chromium: Monthly Vulnerability Update (June 2026)
Palo Alto Networks incorporated the following Chromium security fixes into our products: https://chromereleases.googleblog.com/2026/06/stable-channel-update-for-desktop.html https://chromereleases.googleblog.com/2026/05/stable-channel-update-for-desktop_0877304591.html https://chromereleases.googleblog.com/2026/05/stable-channel-update-for-desktop_0841193308.html https://chromereleases.googleblog.com/2026/05/stable-channel-update-for-desktop_12.html CVE Summary CVE-2026-8509 Heap buffer overflow in WebML CVE-2026-8510 Integer overflow in Skia CVE-2026-8511 Use after free in UI CVE-2026-8512 Use after free in FileSystem CVE-2026-8513 Use after free in Input CVE-2026-8514 Use after free in Aura CVE-2026-8515 Use after free
Red Hat
libsoup: libsoup: HTTP Request Smuggling via permissive chunk-size parsing in soup_body_input_stream_read_chunked()
vendor_redhat·2026-06-05·CVSS 6.5
CVE-2026-66338 [MEDIUM] CWE-444 libsoup: libsoup: HTTP Request Smuggling via permissive chunk-size parsing in soup_body_input_stream_read_chunked()
libsoup: libsoup: HTTP Request Smuggling via permissive chunk-size parsing in soup_body_input_stream_read_chunked()
A flaw was found in libsoup. The chunked transfer encoding parser uses a permissive parsing function for chunk sizes that silently accepts inputs violating RFC 9112, including leading whitespace, plus sign prefixes, and trailing invalid characters. When libsoup operates behind a strict frontend proxy, this parsing differential can be exploited to smuggle HTTP requests.
Statement: A flaw was found in libsoup where the chunked transfer encoding parser uses strtoul() to parse chunk sizes without strict validation, silently accepting inputs that violate RFC 9112. When libsoup operates behind a strict frontend proxy, this parsing differential can be exploited to smuggle HTTP req
Red Hat
chromium-browser: Use after free in GPU
vendor_redhat·2026-05-19·CVSS 8.8
CVE-2026-9112 [HIGH] CWE-825 chromium-browser: Use after free in GPU
chromium-browser: Use after free in GPU
An use after free flaw was found in the GPU component of the Chromium browser.
Upstream bug(s):
https://code.google.com/p/chromium/issues/detail?id=489791425
Statement: Red Hat Product Security rates the severity of this flaw as determined by the Google Chrome Security Advisory.
Chrome
Stable Channel Update for Desktop: CVE-2026-9111
vendor_chrome·2026-05-19·CVSS 4.2
CVE-2026-9111 [CRITICAL] Stable Channel Update for Desktop: CVE-2026-9111
Stable Channel Update for Desktop
CVE-2026-9111: Use after free in WebRTC. Reported by Google on 2026-04-20 [N/A][ 503551154 ] Critical CVE-2026-9110: Inappropriate implementation in UI
Reported by Google on 2026-04-20 [$11000][ 489791425 ] High CVE-2026-9112: Use after free in GPU
Severity: critical
GHSA
Http4s Ember accepts Transfer-Encoding combined with Content-Length (CL.TE request smuggling)
ghsa·2026-09-15
CVE-2026-69204 [CRITICAL] CWE-444 Http4s Ember accepts Transfer-Encoding combined with Content-Length (CL.TE request smuggling)
Http4s Ember accepts Transfer-Encoding combined with Content-Length (CL.TE request smuggling)
## Summary
Ember's HTTP/1.1 request parser does not reject a message that carries both a
`Transfer-Encoding` and a `Content-Length` header. RFC 9112 §6.1 requires a
server to treat such a message as a framing error and close the connection.
An intermediary that follows the RFC's CL-strip-and-forward path (or that
prioritises `Content-Length`) will frame the body differently from Ember,
enabling HTTP request smuggling (CL.TE).
## Impact
### Server
Request smuggling when ember-server is an origin behind an intermediary that
forwards both headers over a keep-alive backend connection and frames by
`Content-Length` while Ember frames by chunked:
- Front-end security bypass: the smuggled request r
VulDB
Google Chrome up to 148.0.7778.168 on Windows GPU use after free
vuldb·2026-05-20·CVSS 8.8
CVE-2026-9112 [HIGH] Google Chrome up to 148.0.7778.168 on Windows GPU use after free
A vulnerability marked as critical has been reported in Google Chrome on Windows. The impacted element is an unknown function of the component GPU. This manipulation causes use after free.
This vulnerability is handled as CVE-2026-9112. The attack can be initiated remotely. There is not any exploit available.
It is suggested to upgrade the affected component.
GHSA
GHSA-j2gw-w7xw-rj29: Use after free in GPU in Google Chrome on Windows prior to 148
ghsa_unreviewed·2026-05-20
CVE-2026-9112 [HIGH] CWE-416 GHSA-j2gw-w7xw-rj29: Use after free in GPU in Google Chrome on Windows prior to 148
Use after free in GPU in Google Chrome on Windows prior to 148.0.7778.179 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-6790 maven4: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
bugzilla·2026-08-05·CVSS 5.3
CVE-2026-6790 [MEDIUM] CVE-2026-6790 maven4: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
CVE-2026-6790 maven4: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority (host and port) matches what provided in the Host header (if present).
This was not enforced in earlier HTTP RFC (for example, in RFC 2616), but it is in the latest RFC (9110 and 9112).
This mismatch can cause a number of problems that may be classified as vulnerabilities such as:
*
URI constructions (for example, for redirects -- this is typical
Bugzilla
CVE-2026-6790 resteasy: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
bugzilla·2026-08-05·CVSS 5.3
CVE-2026-6790 [MEDIUM] CVE-2026-6790 resteasy: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
CVE-2026-6790 resteasy: Jetty: Improper Host header validation can lead to request routing issues [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
In Eclipse Jetty, for HTTP/1, HTTP/2 and HTTP/3 requests, there is no strict check that the request authority (host and port) matches what provided in the Host header (if present).
This was not enforced in earlier HTTP RFC (for example, in RFC 2616), but it is in the latest RFC (9110 and 9112).
This mismatch can cause a number of problems that may be classified as vulnerabilities such as:
*
URI constructions (for example, for redirects -- this is typic
Bugzilla
CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-
bugzilla·2026-05-28·CVSS 4.2
CVE-2026-9110 [MEDIUM] CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-
CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-2026-9124 ... chromium: various flaws [epel-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
Bugzilla
CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-
bugzilla·2026-05-28·CVSS 4.2
CVE-2026-9110 [MEDIUM] CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-
CVE-2026-9110 CVE-2026-9111 CVE-2026-9112 CVE-2026-9113 CVE-2026-9114 CVE-2026-9115 CVE-2026-9116 CVE-2026-9117 CVE-2026-9118 CVE-2026-9119 CVE-2026-9120 CVE-2026-9121 CVE-2026-9122 CVE-2026-9123 CVE-2026-9124 ... chromium: various flaws [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
Bugzilla
CVE-2026-48710 starlette: Starlette: Security restriction bypass via malformed HTTP Host header
bugzilla·2026-05-26·CVSS 6.5
CVE-2026-48710 [MEDIUM] CVE-2026-48710 starlette: Starlette: Security restriction bypass via malformed HTTP Host header
CVE-2026-48710 starlette: Starlette: Security restriction bypass via malformed HTTP Host header
Starlette is a lightweight ASGI framework/toolkit. Prior to version 1.0.1, the HTTP `Host` request header was not validated before being used to reconstruct `request.url`. Because the routing algorithm relies on the raw HTTP path while `request.url` is rebuilt from the `Host` header, a malformed header could make `request.url.path` differ from the path that was actually requested. Middleware and endpoints that apply security restrictions based on `request.url` (rather than the raw `scope` path) could therefore be bypassed. Users should upgrade to a version greater than or equal to version 1.0.1, which validates the `Host` header against the grammar of RFC 9112 §3.2 / RFC 3986 §3.2.2 when constr
Bugzilla
CVE-2026-9112 chromium-browser: Use after free in GPU
bugzilla·2026-05-20·CVSS 8.8
CVE-2026-9112 [HIGH] CVE-2026-9112 chromium-browser: Use after free in GPU
CVE-2026-9112 chromium-browser: Use after free in GPU
Use after free in GPU in Google Chrome on Windows prior to 148.0.7778.179 allowed a remote attacker to execute arbitrary code inside a sandbox via a crafted HTML page. (Chromium security severity: High)
Bugzilla
CVE-2026-1760 libsoup: SoupServer: Denial of Service via HTTP request smuggling
bugzilla·2026-02-02·CVSS 5.3
CVE-2026-1760 [MEDIUM] CVE-2026-1760 libsoup: SoupServer: Denial of Service via HTTP request smuggling
CVE-2026-1760 libsoup: SoupServer: Denial of Service via HTTP request smuggling
HTTP request smuggling vulnerability in SoupServer due to improper handling of requests containing Transfer-Encoding: chunked combined with Connection: keep-alive. Although SoupServer correctly ignores the Content-Length header, it fails to close the connection after responding, in violation of RFC 9112. This allows remaining chunked data to be processed as a subsequent HTTP request. A remote, unauthenticated client can exploit this behavior to smuggle additional requests over a persistent connection, leading to unintended request processing and potential denial-of-service conditions.
2026-05-20
Published