CVE-2026-94637
published 2026-10-02CVE-2026-94637: Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings. This issue affects Apache Thrift: before 0.25.0…
PriorityP344high8.2CVSS 4.0
AVNACLATPPRNUINVCNVINVAHSCNSINSANEXCRXIRXARXMAVXMACXMATXMPRXMUIXMVCXMVIXMVAXMSCXMSIXMSAXSXAUXRXVXREXUX
EPSS
0.28%
20.0th percentile
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Affected
30 ranges· showing 25
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| ansible-automation-platform | automation-orchestrator-temporal-rhel9 | — | — |
| apache | thrift | — | — |
| apache_software_foundation | apache_thrift | < 0.25.0 | 0.25.0 |
| cryostat | cryostat-storage-rhel9 | — | — |
| grafana | grafana | — | — |
| multicluster-globalhub | multicluster-globalhub-grafana-rhel9 | — | — |
| openshift-logging | logging-loki-rhel9 | — | — |
| openshift4 | cnf-tests-rhel8 | — | — |
| openshift4 | oc-mirror-plugin-rhel9 | — | — |
| openshift4 | ztp-site-generate-rhel8 | — | — |
| rhacm2 | acm-grafana-rhel9 | — | — |
| rhaiis | vllm-cpu-rhel9 | — | — |
| rhaiis | vllm-tpu-rhel9 | — | — |
| rhceph-ci | alloy | — | — |
| rhceph-ci | grafana | — | — |
| rhceph-ci | snmp-notifier | — | — |
| rhceph | alloy-rhel10 | — | — |
| rhceph | grafana-rhel10 | — | — |
| rhceph | grafana-rhel9 | — | — |
| rhceph | rhceph-6-dashboard-rhel9 | — | — |
| rhceph | snmp-notifier-rhel10 | — | — |
| rhceph | snmp-notifier-rhel8 | — | — |
| rhceph | snmp-notifier-rhel9 | — | — |
| rhoai | odh-feature-server-rhel9 | — | — |
| rhoai | odh-model-registry-rhel9 | — | — |
CVSS provenance
nvdv4.08.2HIGHCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
vendor_redhat8.2HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
vendor_redhat·2026-10-02·CVSS 8.2
CVE-2026-94637 [HIGH] CWE-409 github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
A flaw was found in the Apache Thrift Go library. A remote attacker could exploit this vulnerability by submitting specially crafted, highly compressed data to an affected service. Due to improper handling during decompression, the resulting data amplification can exhaust system resources, leading to a Denial of Service (DoS).
Package: ansible-automation-platform/automation-orchestrator-temporal-rhel9 (Ansible Automation Orchestrator 2026) - Affected
Package: cryostat/cryostat-storage-rhel9 (Cryostat 4) - Affected
Package: openshift-logging/logging-loki-rhel9 (Logging Subsystem for Red Hat OpenShift) - Affected
Package: multicluster-globalhub/multicluster-globalhub-grafana-rhel9 (Multic
GHSA
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
ghsa_unreviewed·2026-10-02
CVE-2026-94637 [HIGH] CWE-409 Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-94637 migrate: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
bugzilla·2026-10-06·CVSS 8.2
CVE-2026-94637 [HIGH] CVE-2026-94637 migrate: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
CVE-2026-94637 migrate: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Bugzilla
CVE-2026-94637 golang-github-apache-thrift: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
bugzilla·2026-10-06·CVSS 8.2
CVE-2026-94637 [HIGH] CVE-2026-94637 golang-github-apache-thrift: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
CVE-2026-94637 golang-github-apache-thrift: Apache Thrift: Denial of Service via improper handling of compressed data [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
Bugzilla
CVE-2026-94637 github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
bugzilla·2026-10-02·CVSS 8.2
CVE-2026-94637 [HIGH] CVE-2026-94637 github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
CVE-2026-94637 github.com/apache/thrift: Apache Thrift: Denial of Service via improper handling of compressed data
Improper handling of highly compressed data (data amplification) vulnerability in Apache Thrift Go bindings.
This issue affects Apache Thrift: before 0.25.0.
Users are recommended to upgrade to version 0.25.0, which fixes the issue.
2026-10-02
Published