CVE-2026-95387
published 2026-09-29CVE-2026-95387: SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
PriorityP340high8.8CVSS 3.1
AVNACLPRNUIRSUCHIHAH
EPSS
0.26%
17.4th percentile
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
CVSS provenance
nvdv3.18.8HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
vendor_redhat8.1HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
vendor_redhat·2026-09-29·CVSS 8.1
CVE-2026-95387 [HIGH] CWE-787 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
A flaw was found in Wireshark. The SPDY protocol dissector suffers from a heap-based buffer overflow due to improper handling of packet data. A remote attacker could exploit this vulnerability by injecting crafted network packets or enticing a user to inspect a malicious capture file, causing the application to crash and resulting in a Denial of Service (DoS).
Mitigation: Disable the SPDY protocol dissector in Wireshark or TShark to prevent processing of the vulnerable protocol format.
For TShark command-line usage, pass the protocol disable flag:
```
tshark --disable-protocol spdy -r
```
For persistent configuration across sessions, append the protocol to the disabled protocols file:
```
echo "spdy"
GitLab
Heap-based Buffer Overflow in Wireshark
vendor_gitlab·2026-09-29·CVSS 8.1
CVE-2026-95387 [HIGH] CWE-122 Heap-based Buffer Overflow in Wireshark
Heap-based Buffer Overflow in Wireshark
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.19 (affected)
Solution: Upgrade to version 4.6.9 or above
Credit: Security research assessment of Wireshark internals (Feng Xue)
VulDB
Wireshark up to 4.4.18/4.6.8 Dissector denial of service (Nessus ID 362908)
vuldb·2026-10-05·CVSS 8.1
CVE-2026-95387 [HIGH] Wireshark up to 4.4.18/4.6.8 Dissector denial of service (Nessus ID 362908)
A vulnerability was found in Wireshark up to 4.4.18/4.6.8. It has been declared as critical. Affected is an unknown function of the component Dissector. Executing a manipulation can lead to denial of service.
This vulnerability is handled as CVE-2026-95387. The attack can be executed remotely. There is not any exploit available.
It is recommended to upgrade the affected component.
GHSA
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-09-29
CVE-2026-95387 [HIGH] CWE-122 SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
bugzilla·2026-09-29·CVSS 8.1
CVE-2026-95387 [HIGH] CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Bugzilla
CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector [fedora-all]
bugzilla·2026-09-29·CVSS 8.1
CVE-2026-95387 [HIGH] CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector [fedora-all]
CVE-2026-95387 wireshark: wireshark: Denial of Service via heap-based buffer overflow in SPDY dissector [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
SPDY protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
2026-09-29
Published