CVE-2026-96415
published 2026-09-29CVE-2026-96415: Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
PriorityP417medium5.5CVSS 3.1
AVLACLPRNUIRSUCNINAH
EPSS
0.14%
2.8th percentile
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
CVSS provenance
nvdv3.15.5MEDIUMCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
vendor_redhat5.5MEDIUM
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Wireshark up to 4.4.18/4.6.8 Catapult DCT2000 Protocol Dissector denial of service (Nessus ID 362908)
vuldb·2026-10-05·CVSS 5.5
CVE-2026-96415 [MEDIUM] Wireshark up to 4.4.18/4.6.8 Catapult DCT2000 Protocol Dissector denial of service (Nessus ID 362908)
A vulnerability classified as problematic was found in Wireshark up to 4.4.18/4.6.8. The impacted element is an unknown function of the component Catapult DCT2000 Protocol Dissector. The manipulation results in denial of service.
This vulnerability is cataloged as CVE-2026-96415. The attack may be launched remotely. There is no exploit available.
Upgrading the affected component is advised.
GHSA
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-09-29
CVE-2026-96415 [MEDIUM] CWE-121 Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
GitLab
Stack-based Buffer Overflow in Wireshark
vendor_gitlab·2026-09-29·CVSS 5.5
CVE-2026-96415 [MEDIUM] CWE-121 Stack-based Buffer Overflow in Wireshark
Stack-based Buffer Overflow in Wireshark
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.19 (affected)
Solution: Upgrade to version 4.6.9 or above
Credit: Claude and Ada Logics
Red Hat
wireshark: Stack-based Buffer Overflow in Wireshark
vendor_redhat·2026-09-29·CVSS 5.5
CVE-2026-96415 [MEDIUM] CWE-787 wireshark: Stack-based Buffer Overflow in Wireshark
wireshark: Stack-based Buffer Overflow in Wireshark
A flaw was found in Wireshark. The Catapult DCT2000 protocol dissector is susceptible to a crash that results in a Denial of Service (DoS). An attacker could exploit this flaw by injecting malformed network packets or by tricking a user into opening a specially crafted capture file, causing the application to terminate unexpectedly.
Mitigation: Avoid processing packet capture files obtained from untrusted sources and avoid live packet capturing on untrusted networks.
Alternatively, disable the Catapult DCT2000 protocol dissector if it is not required:
1. In the Wireshark GUI, open Analyze -> Enabled Protocols, search for "Catapult DCT2000" (or "dct2000"), uncheck the checkbox, and click OK.
2. For command-line analysis using TShark, sup
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96415 [MEDIUM] CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark
CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Bugzilla
CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark [fedora-all]
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96415 [MEDIUM] CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark [fedora-all]
CVE-2026-96415 wireshark: Stack-based Buffer Overflow in Wireshark [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
Catapult DCT2000 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
2026-09-29
Published