CVE-2026-96416
published 2026-09-29CVE-2026-96416: IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
PriorityP419medium5.5CVSS 3.1
AVLACLPRNUIRSUCNINAH
EPSS
0.14%
2.7th percentile
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
CVSS provenance
nvdv3.15.5MEDIUMCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
vendor_redhat5.5MEDIUM
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
VulDB
Wireshark up to 4.4.18/4.6.8 Dissector denial of service (Nessus ID 362908)
vuldb·2026-10-05·CVSS 5.5
CVE-2026-96416 [MEDIUM] Wireshark up to 4.4.18/4.6.8 Dissector denial of service (Nessus ID 362908)
A vulnerability, which was classified as problematic, has been found in Wireshark up to 4.4.18/4.6.8. This affects an unknown function of the component Dissector. This manipulation causes denial of service.
This vulnerability is registered as CVE-2026-96416. The attack needs to be launched locally. No exploit is available.
It is advisable to upgrade the affected component.
GHSA
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-09-29
CVE-2026-96416 [MEDIUM] CWE-122 IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
GitLab
Heap-based Buffer Overflow in Wireshark
vendor_gitlab·2026-09-29·CVSS 5.5
CVE-2026-96416 [MEDIUM] CWE-122 Heap-based Buffer Overflow in Wireshark
Heap-based Buffer Overflow in Wireshark
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.19 (affected)
Solution: Upgrade to version 4.6.9 or above
Credit: Claude and Ada Logics
Red Hat
wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
vendor_redhat·2026-09-29·CVSS 5.5
CVE-2026-96416 [MEDIUM] CWE-1286 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
A flaw was found in Wireshark. An attacker could exploit this vulnerability by convincing a user to open a specially crafted packet capture file or by injecting malformed IEEE 802.11 wireless network traffic. Processing these invalid packets causes an application crash in the protocol dissector, resulting in a Denial of Service (DoS).
Mitigation: Disable the IEEE 802.11 dissector in Wireshark or avoid processing packet captures from untrusted sources.
1. Dissector configuration:
- In the Wireshark graphical interface, navigate to Analyze -> Enabled Protocols, search for "IEEE 802.11", and deselect it.
- When using command-line tools like TShark, disable the protocol using the `--disable-protocol` flag:
`t
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96416 [MEDIUM] CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Bugzilla
CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing [fedora-all]
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96416 [MEDIUM] CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing [fedora-all]
CVE-2026-96416 wireshark: Wireshark: Denial of Service via malformed IEEE 802.11 packet processing [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
IEEE 802.11 protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
2026-09-29
Published