CVE-2026-96417
published 2026-09-29CVE-2026-96417: RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
PriorityP417medium5.5CVSS 3.1
AVLACLPRNUIRSUCNINAH
EPSS
0.15%
3.5th percentile
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected
6 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| gitlab | wireshark | — | — |
| wireshark | wireshark | — | — |
| wireshark | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
| wireshark_foundation | wireshark | >= 4.4.0 < 4.4.19 | 4.4.19 |
| wireshark_foundation | wireshark | >= 4.6.0 < 4.6.9 | 4.6.9 |
CVSS provenance
nvdv3.15.5MEDIUMCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
vendor_redhat5.5MEDIUM
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
GHSA
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
ghsa_unreviewed·2026-09-29
CVE-2026-96417 [MEDIUM] CWE-122 RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
VulDB
Wireshark RF4CE Packet Parser buffer overflow
vuldb·2026-09-24
CVE-2026-96417 [CRITICAL] Wireshark RF4CE Packet Parser buffer overflow
A vulnerability labeled as critical has been found in Wireshark. This vulnerability affects unknown code of the component RF4CE Packet Parser. Executing a manipulation can lead to buffer overflow.
This vulnerability appears as CVE-2026-96417. The attack may be performed from remote. There is no available exploit.
GitLab
Heap-based Buffer Overflow in Wireshark
vendor_gitlab·2026-09-29·CVSS 5.5
CVE-2026-96417 [MEDIUM] CWE-122 Heap-based Buffer Overflow in Wireshark
Heap-based Buffer Overflow in Wireshark
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Affected products: Wireshark
Affected versions: >=4.6.0, =4.4.0, <4.4.19 (affected)
Solution: Upgrade to version 4.6.9 or above
Credit: Trend Micro's Zero Day Initiative
Red Hat
wireshark: wireshark: Denial of Service via malformed RF4CE packet
vendor_redhat·2026-09-29·CVSS 5.5
CVE-2026-96417 [MEDIUM] CWE-476 wireshark: wireshark: Denial of Service via malformed RF4CE packet
wireshark: wireshark: Denial of Service via malformed RF4CE packet
A flaw was found in Wireshark. By convincing a user to open a specially crafted capture file containing malformed Radio Frequency for Consumer Electronics (RF4CE) network traffic, an attacker can cause the RF4CE protocol dissector to crash. This issue primarily results in a Denial of Service (DoS) by terminating the application.
Mitigation: Disable the RF4CE dissector in Wireshark or tshark to prevent processing of malformed packets:
1. Graphical user interface:
Navigate to Analyze -> Enabled Protocols, search for "RF4CE", uncheck the checkbox, and click OK.
2. Command-line interface (tshark):
Invoke tshark with the protocol disabled:
```
tshark --disable-protocol rf4ce -r
```
3. Configuration file:
Add the protocol ident
No detection rules found.
No public exploits indexed.
Bugzilla
CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96417 [MEDIUM] CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet
CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
Bugzilla
CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet [fedora-all]
bugzilla·2026-09-29·CVSS 5.5
CVE-2026-96417 [MEDIUM] CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet [fedora-all]
CVE-2026-96417 wireshark: wireshark: Denial of Service via malformed RF4CE packet [fedora-all]
Disclaimer: Community trackers are created by Red Hat Product Security team on a best effort basis. Package maintainers are required to ascertain if the flaw indeed affects their package, before starting the update process.
RF4CE protocol dissector crash in 4.6.0 to 4.6.8 and 4.4.0 to 4.4.18 allows denial of service
2026-09-29
Published