Adobe Animate vulnerabilities
109 known vulnerabilities affecting adobe/animate.
Total CVEs
109
CISA KEV
0
Public exploits
1
Exploited in wild
0
Severity breakdown
CRITICAL1HIGH82MEDIUM24LOW2
Vulnerabilities
Page 6 of 6
CVE-2024-30298P4MEDIUMCVSS 5.5≥ 23.0.0, < 23.0.6≥ 24.0.0, < 24.0.3+1 more2024-05-16
CVE-2024-30298 [MEDIUM] CWE-125 CVE-2024-30298: Animate versions 24.0.2, 23.0.5 and earlier Answer: are affected by an out-of-bounds read vulnerabil
Animate versions 24.0.2, 23.0.5 and earlier Answer: are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
CVE-2025-49562P4MEDIUMCVSS 5.5≥ 23.0.0, < 23.0.13≥ 24.0.0, < 24.0.10+1 more2025-08-12
CVE-2025-49562 [MEDIUM] CWE-416 CVE-2025-49562: Animate versions 23.0.12, 24.0.9 and earlier are affected by a Use After Free vulnerability that cou
Animate versions 23.0.12, 24.0.9 and earlier are affected by a Use After Free vulnerability that could lead to disclosure of sensitive memory. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
CVE-2025-54269P4MEDIUMCVSS 5.5≥ 23.0.0, < 23.0.15≥ 24.0.0, < 24.0.12+1 more2025-10-15
CVE-2025-54269 [MEDIUM] CWE-125 CVE-2025-54269: Animate versions 23.0.13, 24.0.10 and earlier are affected by an out-of-bounds read vulnerability th
Animate versions 23.0.13, 24.0.10 and earlier are affected by an out-of-bounds read vulnerability that could lead to memory exposure. An attacker could leverage this vulnerability to disclose sensitive information stored in memory. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
CVE-2025-54270P4MEDIUMCVSS 5.5≥ 23.0.0, < 23.0.15≥ 24.0.0, < 24.0.12+1 more2025-10-15
CVE-2025-54270 [MEDIUM] CWE-476 CVE-2025-54270: Animate versions 23.0.13, 24.0.10 and earlier are affected by a NULL Pointer Dereference vulnerabili
Animate versions 23.0.13, 24.0.10 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to memory exposure. An attacker could leverage this vulnerability to disclose sensitive memory information. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
CVE-2021-42268P4MEDIUMCVSS 5.5≤ 21.0.9≥ unspecified, ≤ 21.0.92021-11-18
CVE-2021-42268 [MEDIUM] CWE-476 CVE-2021-42268: Adobe Animate version 21.0.9 (and earlier) is affected by a Null pointer dereference vulnerability w
Adobe Animate version 21.0.9 (and earlier) is affected by a Null pointer dereference vulnerability when parsing a specially crafted FLA file. An unauthenticated attacker could leverage this vulnerability to achieve an application denial-of-service in the context of the current user. Exploitation of this issue requires user interaction in that a vict
nvd
CVE-2025-30329P4MEDIUMCVSS 5.5≥ 23.0.0, < 23.0.12≥ 24.0.0, < 24.0.9+1 more2025-05-13
CVE-2025-30329 [MEDIUM] CWE-476 CVE-2025-30329: Animate versions 24.0.8, 23.0.11 and earlier are affected by a NULL Pointer Dereference vulnerabilit
Animate versions 24.0.8, 23.0.11 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to application denial-of-service. An attacker could exploit this vulnerability to crash the application, causing disruption of service. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
CVE-2024-20794P4MEDIUMCVSS 5.5fixed in 23.0.5≥ 24.0.0, < 24.0.2+1 more2024-04-11
CVE-2024-20794 [MEDIUM] CWE-476 CVE-2024-20794: Animate versions 23.0.4, 24.0.1 and earlier are affected by a NULL Pointer Dereference vulnerability
Animate versions 23.0.4, 24.0.1 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to an application denial-of-service. An attacker could leverage this vulnerability to cause a system crash, resulting in a denial of service. Exploitation of this issue requires user interaction in that a victim must open a malicious
nvd
CVE-2021-28630P4LOWCVSS 3.3≤ 21.0.6≥ unspecified, ≤ 21.0.62021-08-24
CVE-2021-28630 [LOW] CWE-125 CVE-2021-28630: Adobe Animate version 21.0.6 (and earlier) is affected by an Out-of-bounds Read vulnerability when p
Adobe Animate version 21.0.6 (and earlier) is affected by an Out-of-bounds Read vulnerability when parsing a specially crafted file. An unauthenticated attacker could leverage this vulnerability to disclose potential sensitive information in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open
nvd
CVE-2021-42525P4LOWCVSS 3.3≤ 21.0.9≥ unspecified, ≤ 21.0.92021-11-18
CVE-2021-42525 [LOW] CWE-125 CVE-2021-42525: Acrobat Animate versions 21.0.9 (and earlier)is affected by an out-of-bounds read vulnerability that
Acrobat Animate versions 21.0.9 (and earlier)is affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
nvd
← Previous6 / 6