cbcvebase.

Apache Activemq vulnerabilities

75 known vulnerabilities affecting apache/activemq.

Total CVEs
75
CISA KEV
3
actively exploited
Public exploits
14
Exploited in wild
6
Severity breakdown
CRITICAL13HIGH31MEDIUM28LOW3

Vulnerabilities

Page 4 of 4
CVE-2016-0782P4MEDIUMCVSS 5.4v5.1.0v5.2.0+26 more2016-08-05
CVE-2016-0782 [MEDIUM] CWE-79 CVE-2016-0782: The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13. The administration web console in Apache ActiveMQ 5.x before 5.11.4, 5.12.x before 5.12.3, and 5.13.x before 5.13.2 allows remote authenticated users to conduct cross-site scripting (XSS) attacks and consequently obtain sensitive information from a Java memory dump via vectors related to creating a queue.
nvdosv
CVE-2026-42253P4MEDIUMCVSS 6.1fixed in 5.19.7≥ 6.0.0, < 6.2.62026-06-01
CVE-2026-42253 [MEDIUM] CWE-79 CVE-2026-42253: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability i Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web. The MessageServlet in the ActiveMQ web console API copies every JMS message property into an HTTP response header without any validation. This can allow overwriting and injecting security headers by setting them
nvd
CVE-2026-52760P4MEDIUMCVSS 6.1fixed in 5.19.8≥ 6.0.0, < 6.2.72026-06-30
CVE-2026-52760 [MEDIUM] CWE-79 CVE-2026-52760: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability i Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache ActiveMQ, Apache ActiveMQ Web Console. The browse page in the web console renders a message Id directly without sanitization. This allows an authenticated producer to send a message with a JMS message ID that has been crafted to contain HTML/
nvd
CVE-2012-6551P4MEDIUMCVSS 5.0≤ 5.7.0v4.0+16 more2013-04-21
CVE-2012-6551 [MEDIUM] CWE-399 CVE-2012-6551: The default configuration of Apache ActiveMQ before 5.8.0 enables a sample web application, which al The default configuration of Apache ActiveMQ before 5.8.0 enables a sample web application, which allows remote attackers to cause a denial of service (broker resource consumption) via HTTP requests.
nvd
CVE-2017-15709P4LOWCVSS 3.7≥ 5.14.0, ≤ 5.15.22018-02-13
CVE-2017-15709 [LOW] CWE-200 CVE-2017-15709: When using the OpenWire protocol in ActiveMQ versions 5.14.0 to 5.15.2 it was found that certain sys When using the OpenWire protocol in ActiveMQ versions 5.14.0 to 5.15.2 it was found that certain system details (such as the OS and kernel version) are exposed as plain text.
nvdosv
CVE-2011-4905P4MEDIUMCVSS 5.0≤ 5.5.1v1.1+28 more2012-01-05
CVE-2011-4905 [MEDIUM] CWE-399 CVE-2011-4905: Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor e Apache ActiveMQ before 5.6.0 allows remote attackers to cause a denial of service (file-descriptor exhaustion and broker crash or hang) by sending many openwire failover:tcp:// connection requests.
nvdosv
CVE-2010-1244P4MEDIUMCVSS 6.8≤ 5.3.0v1.1+19 more2010-04-05
CVE-2010-1244 [MEDIUM] CWE-352 CVE-2010-1244: Cross-site request forgery (CSRF) vulnerability in createDestination.action in Apache ActiveMQ befor Cross-site request forgery (CSRF) vulnerability in createDestination.action in Apache ActiveMQ before 5.3.1 allows remote attackers to hijack the authentication of unspecified victims for requests that create queues via the JMSDestination parameter in a queue action.
nvd
CVE-2014-8110P4MEDIUMCVSS 4.3v5.0.0v5.1.0+16 more2015-02-12
CVE-2014-8110 [MEDIUM] CWE-79 CVE-2014-8110: Multiple cross-site scripting (XSS) vulnerabilities in the web based administration console in Apach Multiple cross-site scripting (XSS) vulnerabilities in the web based administration console in Apache ActiveMQ 5.x before 5.10.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
nvd
CVE-2012-6092P4MEDIUMCVSS 4.3≤ 5.7.0v4.0+16 more2013-04-21
CVE-2012-6092 [MEDIUM] CWE-79 CVE-2012-6092: Multiple cross-site scripting (XSS) vulnerabilities in the web demos in Apache ActiveMQ before 5.8.0 Multiple cross-site scripting (XSS) vulnerabilities in the web demos in Apache ActiveMQ before 5.8.0 allow remote attackers to inject arbitrary web script or HTML via (1) the refresh parameter to PortfolioPublishServlet.java (aka demo/portfolioPublish or Market Data Publisher), or vectors involving (2) debug logs or (3) subscribe messages in webapp/web
nvd
CVE-2013-1880P4MEDIUMCVSS 4.3≤ 5.8.0v5.0.0+12 more2014-02-05
CVE-2013-1880 [MEDIUM] CVE-2013-1880: Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet in the demo web applicat Cross-site scripting (XSS) vulnerability in the Portfolio publisher servlet in the demo web application in Apache ActiveMQ before 5.9.0 allows remote attackers to inject arbitrary web script or HTML via the refresh parameter to demo/portfolioPublish, a different vulnerability than CVE-2012-6092.
nvd
CVE-2013-1879P4MEDIUMCVSS 4.3≤ 5.8.0v5.0.0+12 more2013-07-20
CVE-2013-1879 [MEDIUM] CWE-79 CVE-2013-1879: Cross-site scripting (XSS) vulnerability in scheduled.jsp in Apache ActiveMQ 5.8.0 and earlier allow Cross-site scripting (XSS) vulnerability in scheduled.jsp in Apache ActiveMQ 5.8.0 and earlier allows remote attackers to inject arbitrary web script or HTML via vectors involving the "cron of a message."
nvd
CVE-2026-33227P4MEDIUMCVSS 4.3fixed in 5.19.3≥ 6.0.0, < 6.2.22026-04-07
CVE-2026-33227 [MEDIUM] CWE-22 CVE-2026-33227: Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Cli Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to trav
nvd
CVE-2026-46605P4MEDIUMCVSS 4.3fixed in 5.19.7≥ 6.0.0, < 6.2.62026-06-01
CVE-2026-46605 [MEDIUM] CWE-285 CVE-2026-46605: Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authent Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions. This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7
nvd
CVE-2010-0684P4LOWCVSS 3.5≤ 5.3.0v1.1+19 more2010-04-05
CVE-2010-0684 [LOW] CWE-79 CVE-2010-0684: Cross-site scripting (XSS) vulnerability in createDestination.action in Apache ActiveMQ before 5.3.1 Cross-site scripting (XSS) vulnerability in createDestination.action in Apache ActiveMQ before 5.3.1 allows remote authenticated users to inject arbitrary web script or HTML via the JMSDestination parameter in a queue action.
nvd
CVE-2015-7559P4LOWCVSS 2.7fixed in 5.14.5≥ 5.15.0, < 5.15.5+1 more2019-08-01
CVE-2015-7559 [LOW] CWE-306 CVE-2015-7559: It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the It was found that the Apache ActiveMQ client before 5.14.5 exposed a remote shutdown command in the ActiveMQConnection class. An attacker logged into a compromised broker could use this flaw to achieve denial of service on a connected client.
nvdosv
Apache Activemq vulnerabilities | cvebase