Apache Answer vulnerabilities
24 known vulnerabilities affecting apache/answer.
Total CVEs
24
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL2HIGH5MEDIUM15LOW2
Vulnerabilities
Page 2 of 2
CVE-2024-23349P4MEDIUMCVSS 5.4≤ 1.2.12024-02-22
CVE-2024-23349 [MEDIUM] CWE-79 CVE-2024-23349: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability i
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: through 1.2.1.
XSS attack when user enters summary. A logged-in user, when modifying their own submitted question, can input malicious code in the summary to create such an attack.
Users are recommend
nvd
CVE-2024-29217P4MEDIUMCVSS 4.6fixed in 1.3.02024-04-21
CVE-2024-29217 [MEDIUM] CWE-79 CVE-2024-29217: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability i
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Answer.This issue affects Apache Answer: before 1.3.0.
XSS attack when user changes personal website. A logged-in user, when modifying their personal website, can input malicious code in the website to create such an attack.
Users are recomme
nvd
CVE-2023-49619P4LOWCVSS 3.1fixed in 1.2.12024-01-10
CVE-2023-49619 [LOW] CWE-362 CVE-2023-49619: Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerab
Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.2.0.
Under normal circumstances, a user can only bookmark a question once, and will only increase the number of questions bookmarked once. However, repeat submissions through the scrip
nvd
CVE-2024-45719P4LOWCVSS 2.6fixed in 1.4.12024-11-22
CVE-2024-45719 [LOW] CWE-326 CVE-2024-45719: Inadequate Encryption Strength vulnerability in Apache Answer. This issue affects Apache Answer: th
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable.
Users are recommended to upgrade to version 1.4.1, which fixes the issue.
nvd
← Previous2 / 2