cbcvebase.

Apache Apisix vulnerabilities

29 known vulnerabilities affecting apache/apisix.

Total CVEs
29
CISA KEV
2
actively exploited
Public exploits
3
Exploited in wild
2
Severity breakdown
CRITICAL7HIGH14MEDIUM8

Vulnerabilities

Page 2 of 2
CVE-2025-62232P3HIGHCVSS 7.5≥ 1.0, < 3.14.02025-10-31
CVE-2025-62232 [HIGH] CWE-532 CVE-2025-62232: Sensitive data exposure via logging in basic-auth leads to plaintext usernames and passwords written Sensitive data exposure via logging in basic-auth leads to plaintext usernames and passwords written to error logs and forwarded to log sinks when log level is INFO/DEBUG. This creates a high risk of credential compromise through log access. It has been fixed in the following commit: https://github.com/apache/apisix/pull/12629 Users are recommended to
nvd
CVE-2026-31923P3HIGHCVSS 7.5≥ 0.7, < 3.16.02026-04-14
CVE-2026-31923 [HIGH] CWE-319 CVE-2026-31923: Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. This can occur due to `ssl_verify` in openid-connect plugin configuration being set to false by default. This issue affects Apache APISIX: from 0.7 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
nvd
CVE-2025-27446P3HIGHCVSS 7.8≥ 0.2, ≤ 0.52025-07-06
CVE-2025-27446 [HIGH] CWE-732 CVE-2025-27446: Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-run Incorrect Permission Assignment for Critical Resource vulnerability in Apache APISIX(java-plugin-runner). Local listening file permissions in APISIX plugin runner allow a local attacker to elevate privileges. This issue affects Apache APISIX(java-plugin-runner): from 0.2.0 through 0.5.0. Users are recommended to upgrade to version 0.6.0 or higher, w
nvd
CVE-2024-32638P3MEDIUMCVSS 6.3v3.8.0v3.9.02024-05-02
CVE-2024-32638 [MEDIUM] CWE-444 CVE-2024-32638: Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APIS Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0. Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
nvd
CVE-2026-49231P3MEDIUMCVSS 5.4≥ 3.5.0, < 3.17.02026-06-19
CVE-2026-49231 [MEDIUM] CWE-290 CVE-2026-49231: Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed iden Authentication Bypass by Spoofing vulnerability in opa plugin. An attacker could relay spoofed identity headers to upstream capitalising on non-default configuration in opa plugin. This could allow the attacker to assume higher privileges on the upstream service. This issue affects Apache APISIX: from 3.5.0 through 3.16.0. Users are recommended to
nvd
CVE-2026-44046P4MEDIUMCVSS 5.8≥ 1.2, < 3.17.02026-06-19
CVE-2026-44046 [MEDIUM] CWE-348 CVE-2026-44046: Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac Use of Less Trusted Source vulnerability in Apache APISIX. Attacker can take advantage of wolf-rbac plugin under default configuration to potentially pollute logs with spoofed identity information and exploit IP based access control rules. This issue affects Apache APISIX: from 1.2.0 through 3.16.0. Users are recommended to upgrade to version 3.17.
nvd
CVE-2026-44915P4MEDIUMCVSS 6.1≥ 3.0.0, < 3.17.02026-06-19
CVE-2026-44915 [MEDIUM] CWE-601 CVE-2026-44915: URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default con URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX. The default configuration of cas-auth in Apache APISIX is vulnerable to phishing and credential theft. This issue affects Apache APISIX: from 3.0.0 through 3.16.0. Users are recommended to upgrade to version 3.17.0, which fixes the issue.
nvd
CVE-2025-46647P4MEDIUMCVSS 5.3fixed in 3.12.02025-07-02
CVE-2025-46647 [MEDIUM] CWE-302 CVE-2025-46647: A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an imp A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies onl
nvd
CVE-2026-31924P4MEDIUMCVSS 5.3≥ 2.99.0, < 3.16.02026-04-14
CVE-2026-31924 [MEDIUM] CWE-319 CVE-2026-31924: Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. tencent-cloud-cls l Cleartext Transmission of Sensitive Information vulnerability in Apache APISIX. tencent-cloud-cls log export uses plaintext HTTP This issue affects Apache APISIX: from 2.99.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.
nvd
Apache Apisix vulnerabilities | cvebase