Apache Ranger vulnerabilities
31 known vulnerabilities affecting apache/ranger.
Total CVEs
31
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL11HIGH9MEDIUM11
Vulnerabilities
Page 2 of 2
CVE-2015-5167P3MEDIUMCVSS 6.5≤ 0.5.02016-04-12
CVE-2015-5167 [MEDIUM] CWE-264 CVE-2015-5167: The Policy Admin Tool in Apache Ranger before 0.5.1 allows remote authenticated users to bypass inte
The Policy Admin Tool in Apache Ranger before 0.5.1 allows remote authenticated users to bypass intended access restrictions via the REST API.
nvd
CVE-2026-65945P3MEDIUMCVSS 6.5fixed in 2.9.02026-08-10
CVE-2026-65945 [MEDIUM] CWE-532 CVE-2026-65945: Logs contain replayable JWT tokens in Apache Ranger versions <= 2.8.0 Users are recommended to upgra
Logs contain replayable JWT tokens in Apache Ranger versions <= 2.8.0
Users are recommended to upgrade to version 2.9.0, which fixes this issue.
nvd
CVE-2016-6815P4MEDIUMCVSS 6.5v0.4.0v0.5.0+5 more2017-10-13
CVE-2016-6815 [MEDIUM] CWE-255 CVE-2016-6815: In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password f
In Apache Ranger before 0.6.2, users with "keyadmin" role should not be allowed to change password for users with "admin" role.
nvd
CVE-2025-59060P4MEDIUMCVSS 5.3fixed in 2.8.02026-03-03
CVE-2025-59060 [MEDIUM] CWE-297 CVE-2025-59060: Hostname verification bypass issue in Apache Ranger NiFiRegistryClient is reported in Apache Ranger
Hostname verification bypass issue in Apache Ranger NiFiRegistryClient is reported in Apache Ranger versions <= 2.7.0.
Users are recommended to upgrade to version 2.8.0, which fixes this issue.
nvd
CVE-2017-7677P4MEDIUMCVSS 5.9≤ 0.7.02017-06-14
CVE-2017-7677 [MEDIUM] CWE-862 CVE-2017-7677: In environments that use external location for hive tables, Hive Authorizer in Apache Ranger before
In environments that use external location for hive tables, Hive Authorizer in Apache Ranger before 0.7.1 should be checking RWX permission for create table.
nvd
CVE-2015-0265P4MEDIUMCVSS 6.1≤ 0.4.02016-04-11
CVE-2015-0265 [MEDIUM] CWE-79 CVE-2015-0265: Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allo
Cross-site scripting (XSS) vulnerability in the Policy Admin Tool in Apache Ranger before 0.5.0 allows remote attackers to inject arbitrary web script or HTML via the HTTP User-Agent header.
nvd
CVE-2019-12397P4MEDIUMCVSS 6.1≥ 0.7.0, ≤ 1.2.02019-08-08
CVE-2019-12397 [MEDIUM] CWE-79 CVE-2019-12397: Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting
Policy import functionality in Apache Ranger 0.7.0 to 1.2.0 is vulnerable to a cross-site scripting issue. Upgrade to 2.0.0 or later version of Apache Ranger with the fix.
nvd
CVE-2016-8746P4MEDIUMCVSS 5.9≤ 0.6.22017-06-14
CVE-2016-8746 [MEDIUM] CWE-426 CVE-2016-8746: Apache Ranger before 0.6.3 policy engine incorrectly matches paths in certain conditions when policy
Apache Ranger before 0.6.3 policy engine incorrectly matches paths in certain conditions when policy does not contain wildcards and has recursion flag set to true.
nvd
CVE-2016-8751P4MEDIUMCVSS 4.8fixed in 0.6.32017-06-14
CVE-2016-8751 [MEDIUM] CWE-79 CVE-2016-8751: Apache Ranger before 0.6.3 is vulnerable to a Stored Cross-Site Scripting in when entering custom po
Apache Ranger before 0.6.3 is vulnerable to a Stored Cross-Site Scripting in when entering custom policy conditions. Admin users can store some arbitrary javascript code to be executed when normal users login and access policies.
nvd
CVE-2024-45478P4MEDIUMCVSS 4.8≥ 2.4.0, < 2.5.02025-01-21
CVE-2024-45478 [MEDIUM] CWE-79 CVE-2024-45478: Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. Us
Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0.
Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
nvd
CVE-2016-5395P4MEDIUMCVSS 4.8≤ 0.5.0v0.5.1+3 more2016-09-26
CVE-2016-5395 [MEDIUM] CWE-79 CVE-2016-5395: Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool i
Cross-site scripting (XSS) vulnerability in the create user functionality in the policy admin tool in Apache Ranger before 0.6.1 allows remote authenticated administrators to inject arbitrary web script or HTML via vectors related to policies.
nvd
← Previous2 / 2