cbcvebase.

Apache Software Foundation Apache Tomcat Native vulnerabilities

8 known vulnerabilities affecting apache_software_foundation/apache_tomcat_native.

Total CVEs
8
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL2HIGH5MEDIUM1

Vulnerabilities

Page 1 of 1
CVE-2026-29145P2CRITICALCVSS 9.1≥ 1.1.23, ≤ 1.1.34≥ 1.2.0, ≤ 1.2.39+2 more2026-04-09
CVE-2026-29145 [CRITICAL] CWE-287 CVE-2026-29145: CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled v CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through
nvd
CVE-2026-86246P3CRITICALCVSS 9.1≥ 2.0.0, ≤ 2.0.15≥ 1.3.0, ≤ 1.3.82026-09-23
CVE-2026-86246 [CRITICAL] CWE-1188 CVE-2026-86246: Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled Initialization of a resource with an insecure default vulnerability in Apache Tomcat Native enabled insecure options by default including ALLOW_CLIENT_RENEGOTIATION, NO_EXTENDED_MASTER_SECRET, IGNORE_UNEXPECTED_EOF and ALLOW_NO_DHE_KEX. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier unsuppor
nvd
CVE-2026-24734P3HIGHCVSS 7.5≥ 1.1.23, ≤ 1.1.34≥ 1.2.0, ≤ 1.2.39+2 more2026-02-17
CVE-2026-24734 [HIGH] CWE-20 CVE-2026-24734: Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native: from 1.3.0
nvd
CVE-2026-86247P3HIGHCVSS 7.4≥ 2.0.0, ≤ 2.0.15≥ 1.3.0, ≤ 1.3.82026-09-23
CVE-2026-86247 [HIGH] CWE-366 CVE-2026-86247: Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate veri Race condition within a thread vulnerability in Apache Tomcat Native allowed client certificate verification requirements to be down-graded for some configurations. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Unsupported versions may also be affected. Users are recommended to upgrade to version 2.0
nvd
CVE-2018-8019P3HIGHCVSS 7.4v1.2.0 to 1.2.16v1.1.23 to 1.1.342018-07-31
CVE-2018-8019 [HIGH] CWE-295 CVE-2018-8019: When using an OCSP responder Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 did not corre When using an OCSP responder Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 did not correctly handle invalid responses. This allowed for revoked client certificates to be incorrectly identified. It was therefore possible for users to authenticate with revoked certificates when using mutual TLS. Users not using OCSP checks are not affected by
nvd
CVE-2026-86243P3HIGHCVSS 7.5≥ 2.0.0, ≤ 2.0.15≥ 1.3.0, ≤ 1.3.82026-09-23
CVE-2026-86243 [HIGH] CWE-126 CVE-2026-86243: Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious Buffer over-read vulnerability in Apache Tomcat Native during the TLS handshake permits a malicious user to trigger a DoS via a JVM crash. This issue affects Apache Tomcat Native: from 2.0.0 through 2.0.15, from 1.3.0 through 1.3.8. Earlier, unsupported versions may also be affected. Users are recommended to upgrade to version 1.3.9 or 2.0.16, whic
nvd
CVE-2018-8020P3HIGHCVSS 7.4v1.2.0 to 1.2.16v1.1.23 to 1.1.342018-07-31
CVE-2018-8020 [HIGH] CWE-295 CVE-2018-8020: Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 has a flaw that does not properly check OC Apache Tomcat Native 1.2.0 to 1.2.16 and 1.1.23 to 1.1.34 has a flaw that does not properly check OCSP pre-produced responses, which are lists (multiple entries) of certificate statuses. Subsequently, revoked client certificates may not be properly identified, allowing for users to authenticate with revoked certificates to connections that require mutua
nvd
CVE-2017-15698P4MEDIUMCVSS 5.9v1.2.0 to 1.2.14v1.1.23 to 1.1.342018-01-31
CVE-2017-15698 [MEDIUM] CWE-295 CVE-2017-15698: When parsing the AIA-Extension field of a client certificate, Apache Tomcat Native Connector 1.2.0 t When parsing the AIA-Extension field of a client certificate, Apache Tomcat Native Connector 1.2.0 to 1.2.14 and 1.1.23 to 1.1.34 did not correctly handle fields longer than 127 bytes. The result of the parsing error was to skip the OCSP check. It was therefore possible for client certificates that should have been rejected (if the OCSP check had be
nvd
Apache Software Foundation Apache Tomcat Native vulnerabilities | cvebase