Broadcom Rabbitmq Server vulnerabilities
74 known vulnerabilities affecting broadcom/rabbitmq_server.
Total CVEs
74
CISA KEV
0
Public exploits
1
Exploited in wild
0
Severity breakdown
CRITICAL5HIGH22MEDIUM47
Vulnerabilities
Page 4 of 4
CVE-2014-9650P4MEDIUMCVSS 5.0v2.1.0v2.1.1+42 more2015-01-27
CVE-2014-9650 [MEDIUM] CVE-2014-9650: CRLF injection vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 a
CRLF injection vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the download parameter to api/definitions.
nvd
CVE-2026-57214P4MEDIUMCVSS 5.4≥ 4.2.0, < 4.2.52026-07-10
CVE-2026-57214 [MEDIUM] CWE-79 CVE-2026-57214: RabbitMQ is a messaging and streaming broker. Prior to 4.2.5, the RabbitMQ management UI renders the
RabbitMQ is a messaging and streaming broker. Prior to 4.2.5, the RabbitMQ management UI renders the x-internal-purpose queue or exchange argument into an HTML title attribute without proper escaping on the Queues and Exchanges pages, allowing a user with permission to declare a queue or exchange to execute JavaScript in another user's browser. This
nvd
CVE-2026-67415P4MEDIUMCVSS 4.9≥ 4.2.0, < 4.2.9≥ 4.3.0, < 4.3.32026-09-25
CVE-2026-67415 [MEDIUM] CWE-400 CVE-2026-67415: RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.9 and 4.3.3, the Shovel parameter
RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.9 and 4.3.3, the Shovel parameter parser converted attacker-controlled runtime parameter values into non-garbage-collected Erlang atoms before bounding them or checking a fixed allowlist. Exploitation requires network access to the Management HTTP API, valid credentials with both the
nvd
CVE-2017-4967P4MEDIUMCVSS 6.1v3.4.0v3.4.1+9 more2017-06-13
CVE-2017-4967 [MEDIUM] CWE-79 CVE-2017-4967: An issue was discovered in these Pivotal RabbitMQ versions: all 3.4.x versions, all 3.5.x versions,
An issue was discovered in these Pivotal RabbitMQ versions: all 3.4.x versions, all 3.5.x versions, and 3.6.x versions prior to 3.6.9; and these RabbitMQ for PCF versions: all 1.5.x versions, 1.6.x versions prior to 1.6.18, and 1.7.x versions prior to 1.7.15. Several forms in the RabbitMQ management UI are vulnerable to XSS attacks.
nvd
CVE-2026-67226P4MEDIUMCVSS 4.9≥ 4.0.0, < 4.0.22≥ 4.1.0, < 4.1.14+1 more2026-09-25
CVE-2026-67226 [MEDIUM] CWE-400 CVE-2026-67226: RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7, Admin-on
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7, Admin-only atom exhaustion: PUT /api/users tags list. settags/2 maps rabbitdatacoercion:toatom/1 over the user's tags list. The 20 MB management body limit fits ~3-4M short tag strings. An administrator can crash the node in a single request by creating a use
nvd
CVE-2026-67229P4MEDIUMCVSS 4.9≥ 3.13.0, < 3.13.15≥ 4.0.0, < 4.0.20+2 more2026-09-23
CVE-2026-67229 [MEDIUM] CWE-400 CVE-2026-67229: RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, add_vhost/2 calls rabbit_data_coercion:atomize_keys/1 (the unsafe variant using binary_to_atom) on the vhost metadata map. The 20 MB management body limit fits ~1M+ short keys. Admin-only. An administrator importing a crafted definitions file ca
nvd
CVE-2026-67227P4MEDIUMCVSS 4.9≥ 4.0.0, < 4.0.22≥ 4.1.0, < 4.1.14+2 more2026-09-25
CVE-2026-67227 [MEDIUM] CWE-400 CVE-2026-67227: RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.22 and 4.1.14 and 4.2.7 and 4.3.1, Atom exhaustion: toatom on global-parameter :name. resourceexists/2 (and the PUT/DELETE handlers) call rabbitdatacoercion:toatom/1 on the :name URL path segment. toatom/1 uses binarytoatom/2 (unsafe). The endpoint requires policymaker (not managemen
nvd
CVE-2026-66080P4MEDIUMCVSS 4.9≥ 4.1.0, < 4.1.11≥ 4.2.0, < 4.2.62026-09-23
CVE-2026-66080 [MEDIUM] CWE-770 CVE-2026-66080: RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.11, 4.2.6, and 4.3.0, validate_p
RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.11, 4.2.6, and 4.3.0, validate_partitions only checks that the requested partition count is at least 1, with no upper bound. A large count such as lists:seq(0, 500000000) allocates roughly 8GB. Preconditions include The rabbitmq_stream_management plugin must be enabled. The caller n
nvd
CVE-2026-67234P4MEDIUMCVSS 4.3≥ 4.2.0, < 4.2.8≥ 4.3.0, < 4.3.22026-09-25
CVE-2026-67234 [MEDIUM] CWE-20 CVE-2026-67234: RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, get_auth_mechanism/1
RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, get_auth_mechanism/1 used term_to_binary/1 on the strict_auth_mechanism or preferred_auth_mechanism atom when clearing the corresponding cookie, producing a non-ASCII cookie name that violates RFC 6265 and can prevent the browser from deleting the preference. The issue is
nvd
CVE-2026-57213P4MEDIUMCVSS 4.8≥ 3.13.0, < 4.2.52026-07-10
CVE-2026-57213 [MEDIUM] CWE-79 CVE-2026-57213: RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbi
RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_federation_management plugin renders the consumer_tag field on the Federation Status page without HTML escaping, allowing a user who can configure a federation upstream or policy to execute JavaScript in the browser of a user viewing that page. Thi
nvd
CVE-2026-66068P4MEDIUMCVSS 4.4≥ 3.13.0, < 3.13.15≥ 4.0.0, < 4.0.20+2 more2026-09-23
CVE-2026-66068 [MEDIUM] CWE-532 CVE-2026-66068: RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and
RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, ?LOG_DEBUG("shutting down Shovel '~ts', ... Shovel state: ~tp", [Name, State]) formats the entire state map. The 'uris' field holds plaintext URIs after credentials_obfuscation:decrypt (called in rabbit_shovel_util:deobfuscated_uris/2). No forma
nvd
CVE-2019-11291P4MEDIUMCVSS 4.8≥ 3.7.0, < 3.7.20v3.8.02019-11-22
CVE-2019-11291 [MEDIUM] CWE-79 CVE-2019-11291: Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PC
Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site s
nvd
CVE-2026-44839P4MEDIUMCVSS 4.8≥ 3.7.0, < 4.0.13≥ 4.1.0, < 4.1.22026-05-27
CVE-2026-44839 [MEDIUM] CWE-80 CVE-2026-44839: RabbitMQ is a messaging and streaming broker. From 3.7.0 to before 4.1.2 and 4.0.13, This vulnerabi
RabbitMQ is a messaging and streaming broker. From 3.7.0 to before 4.1.2 and 4.0.13, This vulnerability is fixed in 4.1.2 and 4.0.13.
nvd
CVE-2014-9649P4MEDIUMCVSS 4.3v2.1.0v2.1.1+42 more2015-01-27
CVE-2014-9649 [MEDIUM] CWE-79 CVE-2014-9649: Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x be
Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary web script or HTML via the path info to api/, which is not properly handled in an error message.
nvd
← Previous4 / 4