cbcvebase.

Canonical Authd vulnerabilities

5 known vulnerabilities affecting canonical/authd.

Total CVEs
5
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
HIGH3MEDIUM2

Vulnerabilities

Page 1 of 1
CVE-2024-9313P3HIGHCVSS 8.8fixed in 0.3.52024-10-03
CVE-2024-9313 [HIGH] CVE-2024-9313: Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user m Authd PAM module before version 0.3.5 can allow broker-managed users to impersonate any other user managed by the same broker and perform any PAM operation with it, including authenticating as them.
nvd
CVE-2025-5689P3HIGHCVSS 8.5fixed in 0.5.4≥ 0.0.0, ≤ 0.5.42025-06-16
CVE-2025-5689 [HIGH] CWE-269 CVE-2025-5689: A flaw was found in the temporary user record that authd uses in the pre-auth NSS. As a result, a us A flaw was found in the temporary user record that authd uses in the pre-auth NSS. As a result, a user login for the first time will be considered to be part of the root group in the context of that SSH session.
nvd
CVE-2026-6970P3HIGHCVSS 7.3≥ 0.6.0, < 0.6.4≥ 0.6.1, < 0.6.1ubuntu0.12026-04-27
CVE-2026-6970 [HIGH] CWE-842 CVE-2026-6970: authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to authd prior to version 0.6.4 contains a logic error in primary group ID assignment that can lead to local privilege escalation. When a user's primary group ID (GID) differs from their UID, either because the account was created with authd prior to version 0.5.4 or because the primary group was manually changed via the `authctl group set-gid` command, and
nvd
CVE-2024-9312P4MEDIUMCVSS 6.4fixed in 0.3.62024-10-10
CVE-2024-9312 [MEDIUM] CWE-286 CVE-2024-9312: Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions. A local Authd, through version 0.3.6, did not sufficiently randomize user IDs to prevent collisions. A local attacker who can register user names could spoof another user's ID and gain their privileges.
nvd
CVE-2026-102631P4MEDIUMCVSS 5.9≥ 0.1, < 0.7.1≥ 0.1, < 0.7.1~ubuntu24.04.1+1 more2026-10-15
CVE-2026-102631 [MEDIUM] CWE-287 CVE-2026-102631: In authd before 0.7.1, the user identity matching in UpdateUser (internal/users/manager.go) resolves In authd before 0.7.1, the user identity matching in UpdateUser (internal/users/manager.go) resolves an incoming login by the broker-scoped provider ID, but falls back to matching the username when the provider ID does not belong to any known user, and does not reject a conflicting non-empty provider ID. If an identity provider reassigns an email
nvd
Canonical Authd vulnerabilities | cvebase