Dell Appsync vulnerabilities
12 known vulnerabilities affecting dell/appsync.
Total CVEs
12
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL1HIGH5MEDIUM6
Vulnerabilities
Page 1 of 1
CVE-2022-22553P3CRITICALCVSS 9.8≥ unspecified, < 4.42022-01-21
CVE-2022-22553 [CRITICAL] CWE-307 CVE-2022-22553: Dell EMC AppSync versions 3.9 to 4.3 contain an Improper Restriction of Excessive Authentication Att
Dell EMC AppSync versions 3.9 to 4.3 contain an Improper Restriction of Excessive Authentication Attempts Vulnerability that can be exploited from UI and CLI. An adjacent unauthenticated attacker could potentially exploit this vulnerability, leading to password brute-forcing. Account takeover is possible if weak passwords are used by users.
nvd
CVE-2022-24424P3HIGHCVSS 7.5≥ unspecified, < 4.4.0.02022-04-21
CVE-2022-24424 [HIGH] CWE-22 CVE-2022-24424: Dell EMC AppSync versions from 3.9 to 4.3 contain a path traversal vulnerability in AppSync server.
Dell EMC AppSync versions from 3.9 to 4.3 contain a path traversal vulnerability in AppSync server. A remote unauthenticated attacker may potentially exploit this vulnerability to gain unauthorized read access to the files stored on the server filesystem, with the privileges of the running web application.
nvd
CVE-2022-22551P3HIGHCVSS 8.8≥ unspecified, < 4.42022-01-21
CVE-2022-22551 [HIGH] CWE-598 CVE-2022-22551: DELL EMC AppSync versions 3.9 to 4.3 use GET request method with sensitive query strings. An Adjacen
DELL EMC AppSync versions 3.9 to 4.3 use GET request method with sensitive query strings. An Adjacent, unauthenticated attacker could potentially exploit this vulnerability, and hijack the victim session.
nvd
CVE-2026-32657P3HIGHCVSS 7.3fixed in 4.6.0.4 or later2026-08-18
CVE-2026-32657 [HIGH] CWE-61 CVE-2026-32657: Dell AppSync Version 4.6.0.0, Dell Metro Node Version 8.0.0, Dell UCC Edge Version 3.0.1, Dell VxRai
Dell AppSync Version 4.6.0.0, Dell Metro Node Version 8.0.0, Dell UCC Edge Version 3.0.1, Dell VxRail Version 8.0.322, Dell PowerMax Version 10.3.0, Dell Unity Version 5.4, Dell PowerFlex Manager Version 4.5.4, Dell PowerFlex Intelligent Catalog Versions 46.377.00 and 46.382.00 and Dell PowerFlex Rack version 4.5.4 and prior versions, contain(s) an UNI
nvd
CVE-2026-22767P3HIGHCVSS 7.3≥ 4.6.0.0, < 4.6.1.0fixed in 4.6.1.0 or later2026-04-01
CVE-2026-22767 [HIGH] CWE-61 CVE-2026-22767: Dell AppSync, version(s) 4.6.0, contain(s) an UNIX Symbolic Link (Symlink) Following vulnerability.
Dell AppSync, version(s) 4.6.0, contain(s) an UNIX Symbolic Link (Symlink) Following vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Information tampering.
nvd
CVE-2026-22768P3HIGHCVSS 7.3≥ 4.6.0.0, < 4.6.1.0fixed in 4.6.1.0 or later2026-04-01
CVE-2026-22768 [HIGH] CWE-732 CVE-2026-22768: Dell AppSync, version(s) 4.6.0, contain(s) an Incorrect Permission Assignment for Critical Resource
Dell AppSync, version(s) 4.6.0, contain(s) an Incorrect Permission Assignment for Critical Resource vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Elevation of privileges.
nvd
CVE-2025-32744P3MEDIUMCVSS 6.6fixed in 4.6.0.4≥ N/A, < 4.6.0.42025-07-21
CVE-2025-32744 [MEDIUM] CWE-434 CVE-2025-32744: Dell AppSync, version(s) 4.6.0.0, contains an Unrestricted Upload of File with Dangerous Type vulner
Dell AppSync, version(s) 4.6.0.0, contains an Unrestricted Upload of File with Dangerous Type vulnerability. A high privileged attacker with remote access could potentially exploit this vulnerability, leading to Remote execution.
nvd
CVE-2024-22464P4MEDIUMCVSS 6.8≥ 4.2.0.0, ≤ 4.6.0.02024-02-08
CVE-2024-22464 [MEDIUM] CWE-532 CVE-2024-22464: Dell EMC AppSync, versions from 4.2.0.0 to 4.6.0.0 including all Service Pack releases, contain an
Dell EMC AppSync, versions from 4.2.0.0 to 4.6.0.0 including all Service Pack releases, contain an exposure of sensitive information vulnerability in AppSync server logs. A high privileged remote attacker could potentially exploit this vulnerability, leading to the disclosure of certain user credentials. The attacker may be able to use the exposed cre
nvd
CVE-2022-22552P4MEDIUMCVSS 6.1≥ unspecified, < 4.42022-01-21
CVE-2022-22552 [MEDIUM] CWE-1021 CVE-2022-22552: Dell EMC AppSync versions 3.9 to 4.3 contain a clickjacking vulnerability in AppSync. A remote unaut
Dell EMC AppSync versions 3.9 to 4.3 contain a clickjacking vulnerability in AppSync. A remote unauthenticated attacker could potentially exploit this vulnerability to trick the victim into executing state changing operations.
nvd
CVE-2024-52542P4MEDIUMCVSS 5.5≥ 4.6.0.0, < 4.6.0.3v4.6.0.x2024-12-17
CVE-2024-52542 [MEDIUM] CWE-61 CVE-2024-52542: Dell AppSync, version 4.6.0.x, contain a Symbolic Link (Symlink) Following vulnerability. A low priv
Dell AppSync, version 4.6.0.x, contain a Symbolic Link (Symlink) Following vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to information tampering.
nvd
CVE-2025-36603P4MEDIUMCVSS 4.8fixed in 4.6.0.4≥ NA, < 4.6.0.42025-07-21
CVE-2025-36603 [MEDIUM] CWE-611 CVE-2025-36603: Dell AppSync, version(s) 4.6.0.0, contains an Improper Restriction of XML External Entity Reference
Dell AppSync, version(s) 4.6.0.0, contains an Improper Restriction of XML External Entity Reference vulnerability. A low privileged attacker with local access could potentially exploit this vulnerability, leading to Information disclosure and Information tampering.
nvd
CVE-2024-39586P4MEDIUMCVSS 4.3≥ 4.3.0.0, ≤ 4.6.0.02024-10-09
CVE-2024-39586 [MEDIUM] CWE-611 CVE-2024-39586: Dell AppSync Server, version 4.3 through 4.6, contains an XML External Entity Injection vulnerabilit
Dell AppSync Server, version 4.3 through 4.6, contains an XML External Entity Injection vulnerability. An adjacent high privileged attacker could potentially exploit this vulnerability, leading to information disclosure.
nvd