cbcvebase.

Dell Emc Appsync vulnerabilities

6 known vulnerabilities affecting dell/emc_appsync.

Total CVEs
6
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL1HIGH2MEDIUM3

Vulnerabilities

Page 1 of 1
CVE-2022-22553P3CRITICALCVSS 9.8fixed in 4.4.0.02022-01-21
CVE-2022-22553 [CRITICAL] CWE-307 CVE-2022-22553: Dell EMC AppSync versions 3.9 to 4.3 contain an Improper Restriction of Excessive Authentication Att Dell EMC AppSync versions 3.9 to 4.3 contain an Improper Restriction of Excessive Authentication Attempts Vulnerability that can be exploited from UI and CLI. An adjacent unauthenticated attacker could potentially exploit this vulnerability, leading to password brute-forcing. Account takeover is possible if weak passwords are used by users.
nvd
CVE-2022-24424P3HIGHCVSS 7.5≥ 3.9.0.0, < 4.4.0.02022-04-21
CVE-2022-24424 [HIGH] CWE-22 CVE-2022-24424: Dell EMC AppSync versions from 3.9 to 4.3 contain a path traversal vulnerability in AppSync server. Dell EMC AppSync versions from 3.9 to 4.3 contain a path traversal vulnerability in AppSync server. A remote unauthenticated attacker may potentially exploit this vulnerability to gain unauthorized read access to the files stored on the server filesystem, with the privileges of the running web application.
nvd
CVE-2022-22551P3HIGHCVSS 8.8fixed in 4.4.0.02022-01-21
CVE-2022-22551 [HIGH] CWE-598 CVE-2022-22551: DELL EMC AppSync versions 3.9 to 4.3 use GET request method with sensitive query strings. An Adjacen DELL EMC AppSync versions 3.9 to 4.3 use GET request method with sensitive query strings. An Adjacent, unauthenticated attacker could potentially exploit this vulnerability, and hijack the victim session.
nvd
CVE-2024-22464P4MEDIUMCVSS 6.8≥ 4.2.0.0, < 4.6.0.22024-02-08
CVE-2024-22464 [MEDIUM] CWE-532 CVE-2024-22464: Dell EMC AppSync, versions from 4.2.0.0 to 4.6.0.0 including all Service Pack releases, contain an Dell EMC AppSync, versions from 4.2.0.0 to 4.6.0.0 including all Service Pack releases, contain an exposure of sensitive information vulnerability in AppSync server logs. A high privileged remote attacker could potentially exploit this vulnerability, leading to the disclosure of certain user credentials. The attacker may be able to use the exposed cre
nvd
CVE-2022-22552P4MEDIUMCVSS 6.1fixed in 4.4.0.02022-01-21
CVE-2022-22552 [MEDIUM] CWE-1021 CVE-2022-22552: Dell EMC AppSync versions 3.9 to 4.3 contain a clickjacking vulnerability in AppSync. A remote unaut Dell EMC AppSync versions 3.9 to 4.3 contain a clickjacking vulnerability in AppSync. A remote unauthenticated attacker could potentially exploit this vulnerability to trick the victim into executing state changing operations.
nvd
CVE-2024-39586P4MEDIUMCVSS 4.3≥ 4.3.0.0, < 4.6.0.32024-10-09
CVE-2024-39586 [MEDIUM] CWE-611 CVE-2024-39586: Dell AppSync Server, version 4.3 through 4.6, contains an XML External Entity Injection vulnerabilit Dell AppSync Server, version 4.3 through 4.6, contains an XML External Entity Injection vulnerability. An adjacent high privileged attacker could potentially exploit this vulnerability, leading to information disclosure.
nvd
Dell Emc Appsync vulnerabilities | cvebase