cbcvebase.

Gnu Aspell vulnerabilities

8 known vulnerabilities affecting gnu/aspell.

Total CVEs
8
CISA KEV
0
Public exploits
1
Exploited in wild
0
Severity breakdown
CRITICAL2HIGH2MEDIUM1LOW3

Vulnerabilities

Page 1 of 1
CVE-2004-0548P4HIGHCVSS 7.2PoCv0.50.52004-08-06
CVE-2004-0548 [HIGH] CVE-2004-0548: Multiple stack-based buffer overflows in the word-list-compress functionality in compress.c for Aspe Multiple stack-based buffer overflows in the word-list-compress functionality in compress.c for Aspell allow local users to execute arbitrary code via a long entry in the wordlist that is not properly handled when using the (1) "c" compress option or (2) "d" decompress option.
nvdosv
CVE-2019-17544P3CRITICALCVSS 9.1fixed in 0.60.82019-10-14
CVE-2019-17544 [CRITICAL] CWE-125 CVE-2019-17544: libaspell.a in GNU Aspell before 0.60.8 has a stack-based buffer over-read in acommon::unescape in c libaspell.a in GNU Aspell before 0.60.8 has a stack-based buffer over-read in acommon::unescape in common/getdata.cpp via an isolated \ character.
nvdosv
CVE-2019-20433P3CRITICALCVSS 9.1fixed in 0.60.82020-01-27
CVE-2019-20433 [CRITICAL] CWE-125 CVE-2019-20433: libaspell.a in GNU Aspell before 0.60.8 has a buffer over-read for a string ending with a single '\0 libaspell.a in GNU Aspell before 0.60.8 has a buffer over-read for a string ending with a single '\0' byte, if the encoding is set to ucs-2 or ucs-4 outside of the application, as demonstrated by the ASPELL_CONF environment variable.
nvdosv
CVE-2019-25051P3HIGHCVSS 7.8v0.60.82021-07-20
CVE-2019-25051 [HIGH] CWE-787 CVE-2019-25051: objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called objstack in GNU Aspell 0.60.8 has a heap-based buffer overflow in acommon::ObjStack::dup_top (called from acommon::StringMap::add and acommon::Config::lookup_list).
nvdosv
CVE-2026-103658P4MEDIUMCVSS 5.9v0.60.8.22026-10-12
CVE-2026-103658 [MEDIUM] CWE-122 CVE-2026-103658: GNU Aspell 0.60.8.2 (first vulnerable version is not known) contains a heap-based buffer overflow wr GNU Aspell 0.60.8.2 (first vulnerable version is not known) contains a heap-based buffer overflow write (CWE-122) in its read-only dictionary loader. String::reserve() in common/string.hpp computes its capacity check with a signed int ((int)s + 1), so a requested size of 0x7FFFFFFF wraps negative and the backing buffer is never grown. ReadOnlyDict
nvd
CVE-2026-75818P4LOWCVSS 1.8fixed in 0.60.8.32026-10-06
CVE-2026-75818 [LOW] CWE-122 CVE-2026-75818: GNU Aspell prezip-bin contains a heap-based buffer overflow vulnerability in the decompressor in pro GNU Aspell prezip-bin contains a heap-based buffer overflow vulnerability in the decompressor in prog/prezip.c. The decompressor does not properly check buffer space, so a crafted compressed file can cause out-of-bounds read and write operations on the heap. An attacker who convinces a user to process a malicious compressed file with prezip-bin can tri
nvd
CVE-2026-75820P4LOWCVSS 1.8fixed in 0.60.8.32026-10-06
CVE-2026-75820 [LOW] CWE-190 CVE-2026-75820: GNU Aspell contains an integer truncation vulnerability in the WritableDict::add() function in modul GNU Aspell contains an integer truncation vulnerability in the WritableDict::add() function in modules/speller/default/writable.cpp. When loading a personal wordlist, the word length is stored as a single byte, causing truncation for words whose length is a multiple of 256. This leads to heap corruption. An attacker can exploit this by convincing a use
nvd
CVE-2026-75819P4LOWCVSS 1.8fixed in 0.60.8.32026-10-06
CVE-2026-75819 [LOW] CWE-125 CVE-2026-75819: GNU Aspell contains an out-of-bounds read vulnerability in ReadOnlyDict::load() in readonly_ws.cpp. GNU Aspell contains an out-of-bounds read vulnerability in ReadOnlyDict::load() in readonly_ws.cpp. When loading a binary .rws dictionary file, it uses offset fields from the file header as byte indices into a heap buffer without validating their bounds. An attacker can trigger this by convincing a user to run aspell with a crafted dictionary file suppl
nvd
Gnu Aspell vulnerabilities | cvebase