Jpadilla Pyjwt vulnerabilities
21 known vulnerabilities affecting jpadilla/pyjwt.
Total CVEs
21
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL3HIGH10MEDIUM7LOW1
Vulnerabilities
Page 1 of 2
CVE-2026-102266P3CRITICALCVSS 9.1v>= 2.13.0, < 2.14.02026-09-28
CVE-2026-102266 [CRITICAL] CWE-347 CVE-2026-102266: PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorith
PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorithm.from_jwk is affected because PyJWK verification path used the decoded key without applying prepare_key validation. This occurs when a trusted JWK Set contains an oct entry with an empty k value. As a result, an attacker signs an HMAC token with
nvd
CVE-2026-102267P3CRITICALCVSS 9.1fixed in 2.14.02026-09-28
CVE-2026-102267 [CRITICAL] CWE-200 CVE-2026-102267: PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT PyJWKClient is
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT PyJWKClient is affected because redirect destinations are not revalidated against the JWKS trust boundary. This occurs when a configured trusted JWKS endpoint returns an attacker-influenced redirect. As a result, PyJWKClient follows the redirect and consumes the
nvd
CVE-2026-102268P3CRITICALCVSS 9.1fixed in 2.14.02026-09-28
CVE-2026-102268 [CRITICAL] CWE-347 CVE-2026-102268: PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, is_pem_format in jwt/
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, is_pem_format in jwt/utils.py is affected because is_pem_format does not recognize every PEM representation accepted by the cryptography loader. This occurs when an application mixes HMAC and asymmetric algorithms and supplies a mutated public-key PEM as raw key bytes
nvd
CVE-2026-48526P3HIGHCVSS 7.4fixed in 2.13.02026-05-28
CVE-2026-48526 [HIGH] CWE-287 CVE-2026-48526: PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, when the verifier is decoding J
PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, when the verifier is decoding JSON Web Tokens, while supporting both asymmetric and HMAC algorithms, the library does not validate use of JSON Web Keys in HMAC algorithm, allowing attacker to use the issuer public key as the secret key for HMAC algorithm. This vulnerability is fixed
nvd
CVE-2026-102275P3HIGHCVSS 8.2v>= 2.1.0, < 2.15.02026-09-28
CVE-2026-102275 [HIGH] CWE-345 CVE-2026-102275: PyJWT is a Python implementation of JSON Web Token standards. From 2.1.0 until 2.15.0, PyJWT OKPAlgo
PyJWT is a Python implementation of JSON Web Token standards. From 2.1.0 until 2.15.0, PyJWT OKPAlgorithm.from_jwk in jwt/algorithms.py is affected because private-JWK import path does not compare the public key derived from d with x. This occurs when an OKP private JWK supplies non-corresponding x and d components. As a result, identity derived fro
nvd
CVE-2026-102273P3HIGHCVSS 7.4v>= 2.13.0, < 2.14.02026-09-28
CVE-2026-102273 [HIGH] CWE-347 CVE-2026-102273: PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, PyJWT HMACAl
PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, PyJWT HMACAlgorithm.prepare_key is affected because HMAC key guard only recognizes top-level public JWK forms and misses container representations. This occurs when an application allows HMAC and asymmetric algorithms and passes a public JWK container as the raw
nvd
CVE-2026-101917P3HIGHCVSS 7.5fixed in 2.14.02026-09-28
CVE-2026-101917 [HIGH] CWE-770 CVE-2026-101917: PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT get_signing_key
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT get_signing_key_from_jwt is affected because unknown kid misses force refreshes without a negative cache or minimum refresh interval. This occurs when unauthenticated tokens repeatedly use the same unknown kid or varying kid values absent from the cached JWKS. As a
nvd
CVE-2026-102272P3HIGHCVSS 7.4v>= 2.13.0, < 2.14.02026-09-28
CVE-2026-102272 [HIGH] CWE-347 CVE-2026-102272: PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorith
PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, HMACAlgorithm.prepare_key in jwt/algorithms.py is affected because raw-JWK detector does not normalize accepted Unicode byte-order marks before checking for JSON. This occurs when a public JWK is prefixed with a UTF-8 BOM and used in a mixed-algorithm verificatio
nvd
CVE-2026-32597P3HIGHCVSS 7.5fixed in 2.12.02026-03-13
CVE-2026-32597 [HIGH] CWE-345 CVE-2026-32597: PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the cri
PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that PyJWT does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC. Th
nvd
CVE-2026-102274P3HIGHCVSS 7.5v>= 2.9.0, < 2.14.02026-09-28
CVE-2026-102274 [HIGH] CWE-755 CVE-2026-102274: PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does
PyJWT is a Python implementation of JSON Web Token standards. From 2.9.0 until 2.14.0, PyJWKSet does not catch the plain ValueError raised for malformed RSA JWK components by RSAAlgorithm.from_jwk in jwt/api_jwk.py. This occurs when a JWK Set contains a malformed RSA key alongside otherwise usable keys. As a result, one malformed member aborts const
nvd
CVE-2026-101918P3HIGHCVSS 7.5v>= 2.0.0a1, < 2.15.02026-09-28
CVE-2026-101918 [HIGH] CWE-248 CVE-2026-101918: PyJWT is a Python implementation of JSON Web Token standards. From 2.0.0a1 until 2.15.0, PyJWT PyJWK
PyJWT is a Python implementation of JSON Web Token standards. From 2.0.0a1 until 2.15.0, PyJWT PyJWKClient.get_signing_key_from_jwt is affected because payload parser catches ValueError but not RecursionError. This occurs when an attacker-controlled recursively nested payload reaches json.loads. As a result, documented PyJWT exception handling does
nvd
CVE-2024-53861P3HIGHCVSS 7.5v= 2.10.02024-11-29
CVE-2024-53861 [HIGH] CWE-697 CVE-2024-53861: pyjwt is a JSON Web Token implementation in Python. An incorrect string comparison is run for `iss`
pyjwt is a JSON Web Token implementation in Python. An incorrect string comparison is run for `iss` checking, resulting in `"acb"` being accepted for `"_abc_"`. This is a bug introduced in version 2.10.0: checking the "iss" claim changed from `isinstance(issuer, list)` to `isinstance(issuer, Sequence)`. Since str is a Sequnce, but not a list, `in` is a
nvd
CVE-2022-29217P3HIGHCVSS 7.5v>= 2.4.0, < 2.14.02022-05-24
CVE-2022-29217 [HIGH] CWE-327 CVE-2022-29217: PyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorith
PyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorithms. With JWT, an attacker submitting the JWT token can choose the used signing algorithm. The PyJWT library requires that the application chooses what algorithms are supported. The application can specify `jwt.algorithms.get_default_algorithms()` to get
nvd
CVE-2026-103001P3MEDIUMCVSS 6.5v>= 2.11.0, <= 2.13.02026-09-30
CVE-2026-103001 [MEDIUM] CWE-471 CVE-2026-103001: PyJWT is a Python implementation of JSON Web Token standards. From 2.11.0 through 2.13.0, PyJWT's Py
PyJWT is a Python implementation of JSON Web Token standards. From 2.11.0 through 2.13.0, PyJWT's PyJWT._merge_options() method can modify a caller-supplied mutable options mapping when verify_signature is false. If an application reuses that same mapping for a later decode() or decode_complete() call and changes verify_signature to true, the mapp
nvd
CVE-2026-48525P4MEDIUMCVSS 5.3v>= 2.8.0, < 2.13.02026-05-28
CVE-2026-48525 [MEDIUM] CWE-400 CVE-2026-48525: PyJWT is a JSON Web Token implementation in Python. From 2.8.0 to 2.12.1, when verifying detached JW
PyJWT is a JSON Web Token implementation in Python. From 2.8.0 to 2.12.1, when verifying detached JWS tokens using the unencoded-payload option ("b64": false, RFC 7797), PyJWT performs Base64URL decoding of the compact-serialization payload segment before enforcing the detached-payload rules. For b64=false, PyJWT later discards that decoded payload
nvd
CVE-2026-48523P4MEDIUMCVSS 5.4v>= 2.9.0, < 2.13.02026-05-28
CVE-2026-48523 [MEDIUM] CWE-347 CVE-2026-48523: PyJWT is a JSON Web Token implementation in Python. From 2.9.0 to 2.12.1, there is a verifier-side a
PyJWT is a JSON Web Token implementation in Python. From 2.9.0 to 2.12.1, there is a verifier-side algorithm allow-list bypass when jwt.decode() or jwt.decode_complete() are called with a PyJWK key. The token header alg is checked against the caller-supplied algorithms allow-list, but signature verification is performed with the algorithm bound to t
nvd
CVE-2026-102265P4MEDIUMCVSS 5.3v>= 2.13.0, < 2.14.02026-09-28
CVE-2026-102265 [MEDIUM] CWE-674 CVE-2026-102265: PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, PyJWS._load
PyJWT is a Python implementation of JSON Web Token standards. From 2.13.0 until 2.14.0, PyJWS._load in jwt/api_jws.py is affected because parser catches ValueError but not RecursionError. This occurs when a deeply nested token header reaches json.loads. As a result, RecursionError escapes the documented PyJWT error hierarchy. Consequently, an unaut
nvd
CVE-2026-102269P4MEDIUMCVSS 5.4fixed in 2.14.02026-09-28
CVE-2026-102269 [MEDIUM] CWE-180 CVE-2026-102269: PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT signature segme
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT signature segment is affected because signature segment decoding accepts characters outside the canonical Base64URL representation. This occurs when non-Base64URL characters are appended to a valid compact JWS signature segment. As a result, base64url_decode produ
nvd
CVE-2026-102270P4MEDIUMCVSS 4.9fixed in 2.14.02026-09-28
CVE-2026-102270 [MEDIUM] CWE-1333 CVE-2026-102270: PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT is_pem_format i
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT is_pem_format is affected because lazy PEM regular expression backtracks extensively. This occurs when a certificate-like input contains repeated BEGIN markers without a matching END marker. As a result, is_pem_format performs unbounded backtracking while searchi
nvd
CVE-2026-48522P4MEDIUMCVSS 4.2fixed in 2.13.02026-05-28
CVE-2026-48522 [MEDIUM] CWE-441 CVE-2026-48522: PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, PyJWKClient passes its uri argu
PyJWT is a JSON Web Token implementation in Python. Prior to 2.13.0, PyJWKClient passes its uri argument directly to urllib.request.urlopen() which uses Python stdlib's default OpenerDirector registering HTTPHandler, HTTPSHandler, FTPHandler, FileHandler, and DataHandler. There is currently no documented option to restrict which schemes PyJWKClient
nvd
1 / 2Next →