Microsoft Windows 10 vulnerabilities
2,805 known vulnerabilities affecting microsoft/windows_10.
Total CVEs
2,805
CISA KEV
7
actively exploited
Public exploits
226
Exploited in wild
52
Severity breakdown
CRITICAL68HIGH1906MEDIUM804LOW27
Vulnerabilities
Page 108 of 141
CVE-2018-0816P4HIGHCVSS 7.0v1511v1607+2 more2018-03-14
CVE-2018-0816 [HIGH] CVE-2018-0816: The Windows Graphics Device Interface (GDI) in Microsoft Windows Server 2008 SP2 and R2 SP1, Windows
The Windows Graphics Device Interface (GDI) in Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1 and RT 8.1, Windows Server 2012 and R2, Windows 10 Gold, 1511, 1607, 1703, and 1709, Windows Server 2016 and Windows Server, version 1709 allows an elevation of privilege vulnerability due to the way objects are handled in memory, aka "Windows
nvd
CVE-2018-0868P4HIGHCVSS 7.0v1511v1607+2 more2018-03-14
CVE-2018-0868 [HIGH] CWE-20 CVE-2018-0868: Windows Installer in Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1 and RT
Windows Installer in Microsoft Windows Server 2008 SP2 and R2 SP1, Windows 7 SP1, Windows 8.1 and RT 8.1, Windows Server 2012 and R2, Windows 10 Gold, 1511, 1607, 1703, and 1709, Windows Server 2016 and Windows Server, version 1709 allows an elevation of privilege vulnerability due to how input is sanitized, aka "Windows Installer Elevation of Privilege
nvd
CVE-2018-0809P4HIGHCVSS 7.0v1703v17092018-02-15
CVE-2018-0809 [HIGH] CVE-2018-0809: The Windows kernel in Windows 10, versions 1703 and 1709, and Windows Server, version 1709 allows an
The Windows kernel in Windows 10, versions 1703 and 1709, and Windows Server, version 1709 allows an elevation of privilege vulnerability due to the way objects are handled in memory, aka "Windows Elevation of Privilege Vulnerability". This CVE is unique from CVE-2018-0742, CVE-2018-0756, CVE-2018-0820 and CVE-2018-0843.
nvd
CVE-2018-0983P4HIGHCVSS 7.0v1511v1607+2 more2018-03-14
CVE-2018-0983 [HIGH] CVE-2018-0983: Windows Storage Services in Windows 10 versions 1511, 1607, 1703 and 1709, Windows Server 2016 and W
Windows Storage Services in Windows 10 versions 1511, 1607, 1703 and 1709, Windows Server 2016 and Windows Server, version 1709 allows an elevation of privilege vulnerability due to the way objects are handled in memory, aka "Windows Storage Services Elevation of Privilege Vulnerability".
nvd
CVE-2022-22717P4HIGHCVSS 7.0v20h2v21h1+4 more2022-02-09
CVE-2022-22717 [HIGH] CVE-2022-22717: Windows Print Spooler Elevation of Privilege Vulnerability
Windows Print Spooler Elevation of Privilege Vulnerability
nvd
CVE-2022-21868P4HIGHCVSS 7.0v20h2v21h1+4 more2022-01-11
CVE-2022-21868 [HIGH] CVE-2022-21868: Windows Devices Human Interface Elevation of Privilege Vulnerability
Windows Devices Human Interface Elevation of Privilege Vulnerability
nvd
CVE-2022-29126P4HIGHCVSS 7.0v20h2v21h1+4 more2022-05-10
CVE-2022-29126 [HIGH] CVE-2022-29126: Tablet Windows User Interface Application Core Elevation of Privilege Vulnerability
Tablet Windows User Interface Application Core Elevation of Privilege Vulnerability
nvd
CVE-2022-21859P4HIGHCVSS 7.0v20h2v21h1+3 more2022-01-11
CVE-2022-21859 [HIGH] CVE-2022-21859: Windows Accounts Control Elevation of Privilege Vulnerability
Windows Accounts Control Elevation of Privilege Vulnerability
nvd
CVE-2022-21866P4HIGHCVSS 7.0v20h2v21h1+4 more2022-01-11
CVE-2022-21866 [HIGH] CVE-2022-21866: Windows System Launcher Elevation of Privilege Vulnerability
Windows System Launcher Elevation of Privilege Vulnerability
nvd
CVE-2022-22016P4HIGHCVSS 7.0v20h2v21h1+4 more2022-05-10
CVE-2022-22016 [HIGH] CVE-2022-22016: Windows PlayToManager Elevation of Privilege Vulnerability
Windows PlayToManager Elevation of Privilege Vulnerability
nvd
CVE-2022-41114P4HIGHCVSS 7.0v20h2v21h1+2 more2022-11-09
CVE-2022-41114 [HIGH] CWE-362 CVE-2022-41114: Windows Bind Filter Driver Elevation of Privilege Vulnerability
Windows Bind Filter Driver Elevation of Privilege Vulnerability
nvd
CVE-2022-30224P4HIGHCVSS 7.0v20h2v21h1+3 more2022-07-12
CVE-2022-30224 [HIGH] CVE-2022-30224: Windows Advanced Local Procedure Call (ALPC) Elevation of Privilege Vulnerability
Windows Advanced Local Procedure Call (ALPC) Elevation of Privilege Vulnerability
nvd
CVE-2022-22036P4HIGHCVSS 7.0v20h2v21h1+3 more2022-07-12
CVE-2022-22036 [HIGH] CVE-2022-22036: Performance Counters for Windows Elevation of Privilege Vulnerability
Performance Counters for Windows Elevation of Privilege Vulnerability
nvd
CVE-2022-38021P4HIGHCVSS 7.0v20h2v21h1+3 more2022-10-11
CVE-2022-38021 [HIGH] CWE-362 CVE-2022-38021: Connected User Experiences and Telemetry Elevation of Privilege Vulnerability
Connected User Experiences and Telemetry Elevation of Privilege Vulnerability
nvd
CVE-2023-21771P4HIGHCVSS 7.0v20h2v21h2+1 more2023-01-10
CVE-2023-21771 [HIGH] CWE-591 CVE-2023-21771: Windows Local Session Manager (LSM) Elevation of Privilege Vulnerability
Windows Local Session Manager (LSM) Elevation of Privilege Vulnerability
nvd
CVE-2022-30205P4MEDIUMCVSS 6.6v20h2v21h1+3 more2022-07-12
CVE-2022-30205 [MEDIUM] CWE-362 CVE-2022-30205: Windows Group Policy Elevation of Privilege Vulnerability
Windows Group Policy Elevation of Privilege Vulnerability
nvd
CVE-2023-21694P4MEDIUMCVSS 6.8fixed in 10.0.10240.197472023-02-14
CVE-2023-21694 [MEDIUM] CWE-122 CVE-2023-21694: Windows Fax Service Remote Code Execution Vulnerability
Windows Fax Service Remote Code Execution Vulnerability
nvd
CVE-2017-8623P4MEDIUMCVSS 6.8v1607v17032017-08-08
CVE-2017-8623 [MEDIUM] CWE-20 CVE-2017-8623: Windows Hyper-V in Windows 10 1607, 1703, and Windows Server 2016 allows a denial of service vulnera
Windows Hyper-V in Windows 10 1607, 1703, and Windows Server 2016 allows a denial of service vulnerability when it fails to properly validate input from a privileged user on a guest operating system, aka "Windows Hyper-V Denial of Service Vulnerability".
nvd
CVE-2020-15706P4MEDIUMCVSS 6.4v1607v1709+5 more2020-07-29
CVE-2020-15706 [MEDIUM] CWE-362 CVE-2020-15706: GRUB2 contains a race condition in grub_script_function_create() leading to a use-after-free vulnera
GRUB2 contains a race condition in grub_script_function_create() leading to a use-after-free vulnerability which can be triggered by redefining a function whilst the same function is already executing, leading to arbitrary code execution and secure boot restriction bypass. This issue affects GRUB2 version 2.04 and prior versions.
nvd
CVE-2022-21924P4MEDIUMCVSS 5.3v20h2v21h1+4 more2022-01-11
CVE-2022-21924 [MEDIUM] CVE-2022-21924: Workstation Service Remote Protocol Security Feature Bypass Vulnerability
Workstation Service Remote Protocol Security Feature Bypass Vulnerability
nvd