Neovim vulnerabilities
29 known vulnerabilities affecting neovim/neovim.
Total CVEs
29
CISA KEV
0
Public exploits
1
Exploited in wild
0
Severity breakdown
HIGH20MEDIUM9
Vulnerabilities
Page 1 of 2
CVE-2019-12735P2HIGHCVSS 8.6PoCfixed in 0.3.62019-06-05
CVE-2019-12735 [HIGH] CWE-78 CVE-2019-12735: getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrar
getchar.c in Vim before 8.1.1365 and Neovim before 0.3.6 allows remote attackers to execute arbitrary OS commands via the :source! command in a modeline, as demonstrated by execute in Vim, and assert_fails or nvim_input in Neovim.
nvdosv
CVE-2022-4141P3HIGHCVSS 7.8≥ 0.1.0, < 0.10.02022-11-25
CVE-2022-4141 [HIGH] CWE-122 CVE-2022-4141: Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the
Heap based buffer overflow in vim/vim 9.0.0946 and below by allowing an attacker to CTRL-W gf in the expression used in the RHS of the substitute command.
nvd
CVE-2023-4781P3HIGHCVSS 7.8≤ 0.9.52023-09-05
CVE-2023-4781 [HIGH] CWE-122 CVE-2023-4781: Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1873.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1873.
nvd
CVE-2023-4738P4HIGHCVSS 7.8fixed in 0.10.02023-09-02
CVE-2023-4738 [HIGH] CWE-122 CVE-2023-4738: Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1848.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1848.
nvd
CVE-2023-4752P4HIGHCVSS 7.8≥ 0.5.0, < 0.10.02023-09-04
CVE-2023-4752 [HIGH] CWE-416 CVE-2023-4752: Use After Free in GitHub repository vim/vim prior to 9.0.1858.
Use After Free in GitHub repository vim/vim prior to 9.0.1858.
nvd
CVE-2023-4751P3HIGHCVSS 7.8fixed in 0.9.02023-09-03
CVE-2023-4751 [HIGH] CWE-122 CVE-2023-4751: Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1331.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1331.
nvd
CVE-2022-3296P4HIGHCVSS 7.8≥ 0.1.0, < 0.9.02022-09-25
CVE-2022-3296 [HIGH] CWE-121 CVE-2022-3296: Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0577.
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0577.
nvd
CVE-2023-4750P4HIGHCVSS 7.8fixed in 0.10.02023-09-04
CVE-2023-4750 [HIGH] CWE-416 CVE-2023-4750: Use After Free in GitHub repository vim/vim prior to 9.0.1857.
Use After Free in GitHub repository vim/vim prior to 9.0.1857.
nvd
CVE-2022-3324P4HIGHCVSS 7.8≥ 0.1.0, < 0.9.52022-09-27
CVE-2022-3324 [HIGH] CWE-121 CVE-2022-3324: Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0598.
Stack-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0598.
nvd
CVE-2023-4733P4HIGHCVSS 7.8≥ 0.7.0, < 0.9.22023-09-04
CVE-2023-4733 [HIGH] CWE-416 CVE-2023-4733: Use After Free in GitHub repository vim/vim prior to 9.0.1840.
Use After Free in GitHub repository vim/vim prior to 9.0.1840.
nvd
CVE-2023-0433P4HIGHCVSS 7.8≥ 0.1.0, < 0.8.32023-01-21
CVE-2023-0433 [HIGH] CWE-122 CVE-2023-0433: Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1225.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1225.
nvd
CVE-2022-3134P4HIGHCVSS 7.8≥ 0.5.0, < 0.9.02022-09-06
CVE-2022-3134 [HIGH] CWE-416 CVE-2022-3134: Use After Free in GitHub repository vim/vim prior to 9.0.0389.
Use After Free in GitHub repository vim/vim prior to 9.0.0389.
nvd
CVE-2023-4734P4HIGHCVSS 7.8≥ 0.7.0, < 0.10.02023-09-02
CVE-2023-4734 [HIGH] CWE-190 CVE-2023-4734: Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1846.
Integer Overflow or Wraparound in GitHub repository vim/vim prior to 9.0.1846.
nvd
CVE-2022-3037P4HIGHCVSS 7.8≥ 0.5.0, < 0.9.02022-08-30
CVE-2022-3037 [HIGH] CWE-416 CVE-2022-3037: Use After Free in GitHub repository vim/vim prior to 9.0.0322.
Use After Free in GitHub repository vim/vim prior to 9.0.0322.
nvd
CVE-2022-3297P4HIGHCVSS 7.8≥ 0.5.0, < 0.10.02022-09-25
CVE-2022-3297 [HIGH] CWE-416 CVE-2022-3297: Use After Free in GitHub repository vim/vim prior to 9.0.0579.
Use After Free in GitHub repository vim/vim prior to 9.0.0579.
nvd
CVE-2023-5535P4HIGHCVSS 7.8≤ 0.9.52023-10-11
CVE-2023-5535 [HIGH] CWE-416 CVE-2023-5535: Use After Free in GitHub repository vim/vim prior to v9.0.2010.
Use After Free in GitHub repository vim/vim prior to v9.0.2010.
nvd
CVE-2023-0288P4HIGHCVSS 7.8≤ 0.8.32023-01-13
CVE-2023-0288 [HIGH] CWE-122 CVE-2023-0288: Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1189.
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1189.
nvd
CVE-2022-3256P4HIGHCVSS 7.8≥ 0.1.0, < 0.8.02022-09-22
CVE-2022-3256 [HIGH] CWE-416 CVE-2022-3256: Use After Free in GitHub repository vim/vim prior to 9.0.0530.
Use After Free in GitHub repository vim/vim prior to 9.0.0530.
nvd
CVE-2023-0049P4HIGHCVSS 7.8≥ 0.1.0, < 0.10.02023-01-04
CVE-2023-0049 [HIGH] CWE-125 CVE-2023-0049: Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143.
Out-of-bounds Read in GitHub repository vim/vim prior to 9.0.1143.
nvd
CVE-2022-3591P4HIGHCVSS 7.8≥ 0.1.0, < 0.9.02022-12-02
CVE-2022-3591 [HIGH] CWE-416 CVE-2022-3591: Use After Free in GitHub repository vim/vim prior to 9.0.0789.
Use After Free in GitHub repository vim/vim prior to 9.0.0789.
nvd
1 / 2Next →