cbcvebase.

Oracle Goldengate vulnerabilities

33 known vulnerabilities affecting oracle/goldengate.

Total CVEs
33
CISA KEV
0
Public exploits
2
Exploited in wild
0
Severity breakdown
CRITICAL5HIGH14MEDIUM14

Vulnerabilities

Page 2 of 2
CVE-2019-3740P4MEDIUMCVSS 6.5fixed in 19.1.0.0.0.2104202019-09-18
CVE-2019-3740 [MEDIUM] CWE-310 CVE-2019-3740: RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to an Information Exposure Through Timing RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to an Information Exposure Through Timing Discrepancy vulnerabilities during DSA key generation. A malicious remote attacker could potentially exploit those vulnerabilities to recover DSA keys.
nvd
CVE-2019-3738P4MEDIUMCVSS 6.5fixed in 19.1.0.0.0.210420v19.1.0.0.0.2104202019-09-18
CVE-2019-3738 [MEDIUM] CWE-325 CVE-2019-3738: RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to a Missing Required Cryptographic Step v RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to a Missing Required Cryptographic Step vulnerability. A malicious remote attacker could potentially exploit this vulnerability to coerce two parties into computing the same predictable shared key.
nvd
CVE-2026-60394P4MEDIUMCVSS 5.3≥ 21.3.0, ≤ 21.21.0.0.0≥ 23.4, ≤ 23.26.1.0.02026-07-21
CVE-2026-60394 [MEDIUM] CWE-200 CVE-2026-60394: Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that ar Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that are affected are 21.3-21.21 and 23.4-23.26.1. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTPS to compromise Oracle GoldenGate. Successful attacks of this vulnerability can result in unauthorized read access t
nvd
CVE-2019-3739P4MEDIUMCVSS 6.5fixed in 19.1.0.0.0.2104202019-09-18
CVE-2019-3739 [MEDIUM] CWE-310 CVE-2019-3739: RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to Information Exposure Through Timing Dis RSA BSAFE Crypto-J versions prior to 6.2.5 are vulnerable to Information Exposure Through Timing Discrepancy vulnerabilities during ECDSA key generation. A malicious remote attacker could potentially exploit those vulnerabilities to recover ECDSA keys.
nvd
CVE-2022-21551P4MEDIUMCVSS 6.8≥ 19.1.0.0.0, < 19.1.0.0.220719≥ 21.1.0, < 21.7.0.0.02022-07-19
CVE-2022-21551 [MEDIUM] CVE-2022-21551: Vulnerability in Oracle GoldenGate (component: Oracle GoldenGate). The supported version that is aff Vulnerability in Oracle GoldenGate (component: Oracle GoldenGate). The supported version that is affected is 21c: prior to 21.7.0.0.0; 19c: prior to 19.1.0.0.220719. Easily exploitable vulnerability allows high privileged attacker with network access via HTTP to compromise Oracle GoldenGate. Successful attacks require human interaction from a person other t
nvd
CVE-2026-34273P4MEDIUMCVSS 5.3≥ 23.4, ≤ 23.102026-04-21
CVE-2026-34273 [MEDIUM] CWE-200 CVE-2026-34273: Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are 23.4-23.10. Easily exploitable vulnerability allows unauthenticated attacker with network access via HTTP to compromise Oracle GoldenGate. Successful attacks of this vulnerability can result in unauthorized read access to a subset of Oracle GoldenGate
nvd
CVE-2019-10219P4MEDIUMCVSS 6.1fixed in 12.3.0.1≥ 19.0.0, < 19.1.0.0.220118+1 more2019-11-08
CVE-2019-10219 [MEDIUM] CWE-79 CVE-2019-10219: A vulnerability was found in Hibernate-Validator. The SafeHtml validator annotation fails to properl A vulnerability was found in Hibernate-Validator. The SafeHtml validator annotation fails to properly sanitize payloads consisting of potentially malicious code in HTML comments and instructions. This vulnerability can result in an XSS attack.
nvd
CVE-2016-0450P4MEDIUMCVSS 5.0v11.2v12.1.22016-01-21
CVE-2016-0450 [MEDIUM] CVE-2016-0450: Unspecified vulnerability in the Oracle GoldenGate component in Oracle GoldenGate 11.2 and 12.1.2 al Unspecified vulnerability in the Oracle GoldenGate component in Oracle GoldenGate 11.2 and 12.1.2 allows remote attackers to affect availability via unknown vectors.
nvd
CVE-2019-14862P4MEDIUMCVSS 6.1v12.3.0.1.22020-01-02
CVE-2019-14862 [MEDIUM] CWE-79 CVE-2019-14862: There is a vulnerability in knockout before version 3.5.0-beta, where after escaping the context of There is a vulnerability in knockout before version 3.5.0-beta, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, without validating it.
nvd
CVE-2026-61079P4MEDIUMCVSS 5.8≥ 19.1.0.0.0, ≤ 19.30.0.0≥ 21.3.0, ≤ 21.21.0.0.0+1 more2026-07-21
CVE-2026-61079 [MEDIUM] CWE-20 CVE-2026-61079: Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are 19.1.0.0.0-19.30.0.0, 21.3-21.21 and 23.4-23.26.2. Difficult to exploit vulnerability allows high privileged attacker with logon to the infrastructure where Oracle GoldenGate executes to compromise Oracle GoldenGate. Successful attacks require human int
nvd
CVE-2026-60395P4MEDIUMCVSS 4.3≥ 19.1.0.0.0, ≤ 19.30.0.0≥ 21.3.0, ≤ 21.21.0.0.0+1 more2026-07-21
CVE-2026-60395 [MEDIUM] CWE-200 CVE-2026-60395: Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that a Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that are affected are 19.1.0.0.0-19.30.0.0, 21.3-21.21 and 23.4-23.26.1. Easily exploitable vulnerability allows low privileged attacker with network access via HTTP to compromise Oracle GoldenGate. Successful attacks of this vulnerability can result in unautho
nvd
CVE-2026-60397P4MEDIUMCVSS 4.3≥ 19.1.0.0.0, ≤ 19.30.0.0≥ 21.3.0, ≤ 21.21.0.0.0+1 more2026-07-21
CVE-2026-60397 [MEDIUM] CWE-404 CVE-2026-60397: Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that ar Vulnerability in Oracle GoldenGate (component: Admin Server Executable). Supported versions that are affected are 19.1.0.0.0-19.30.0.0, 21.3-21.21 and 23.4-23.26.1. Easily exploitable vulnerability allows unauthenticated attacker with access to the physical communication segment attached to the hardware where the Oracle GoldenGate executes to comprom
nvd
CVE-2026-61084P4MEDIUMCVSS 4.4≥ 19.1.0.0.0, ≤ 19.30.0.0≥ 21.3.0, ≤ 21.21.0.0.0+1 more2026-07-21
CVE-2026-61084 [MEDIUM] CWE-284 CVE-2026-61084: Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are Vulnerability in Oracle GoldenGate (component: Libraries). Supported versions that are affected are 19.1.0.0.0-19.30.0.0, 21.3-21.21 and 23.4-23.26.2. Easily exploitable vulnerability allows low privileged attacker with logon to the infrastructure where Oracle GoldenGate executes to compromise Oracle GoldenGate. Successful attacks of this vulnerabili
nvd
Oracle Goldengate vulnerabilities | cvebase