cbcvebase.

Rabbitmq Rabbitmq-Server vulnerabilities

90 known vulnerabilities affecting rabbitmq/rabbitmq-server.

Total CVEs
90
CISA KEV
0
Public exploits
1
Exploited in wild
0
Severity breakdown
CRITICAL5HIGH22MEDIUM60LOW3

Vulnerabilities

Page 5 of 5
CVE-2026-57213P4MEDIUMCVSS 4.8v>= 4.2.0, < 4.2.5v>= 4.1.0, < 4.1.10+2 more2026-07-10
CVE-2026-57213 [MEDIUM] CWE-79 CVE-2026-57213: RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbi RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_federation_management plugin renders the consumer_tag field on the Federation Status page without HTML escaping, allowing a user who can configure a federation upstream or policy to execute JavaScript in the browser of a user viewing that page. Thi
nvd
CVE-2021-32719P4MEDIUMCVSS 4.8fixed in 3.8.182021-06-28
CVE-2021-32719 [MEDIUM] CWE-80 CVE-2021-32719: RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a fe RabbitMQ is a multi-protocol messaging broker. In rabbitmq-server prior to version 3.8.18, when a federation link was displayed in the RabbitMQ management UI via the `rabbitmq_federation_management` plugin, its consumer tag was rendered without proper tag sanitization. This potentially allows for JavaScript code execution in the context of the page.
nvdosv
CVE-2019-11281P4MEDIUMCVSS 4.8≥ 0, < 3.7.18-12019-10-16
CVE-2019-11281 [MEDIUM] CVE-2019-11281: Pivotal RabbitMQ, versions prior to v3 Pivotal RabbitMQ, versions prior to v3.7.18, and RabbitMQ for PCF, versions 1.15.x prior to 1.15.13, versions 1.16.x prior to 1.16.6, and versions 1.17.x prior to 1.17.3, contain two components, the virtual host limits page, and the federation management UI, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack that would g
osv
CVE-2026-66068P4MEDIUMCVSS 4.4v>= 3.13.0, < 3.13.15v>= 4.0.0, < 4.0.20+2 more2026-09-23
CVE-2026-66068 [MEDIUM] CWE-532 CVE-2026-66068: RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and RabbitMQ is a messaging and streaming broker. Prior to versions 3.13.15, 4.0.20, 4.1.11, 4.2.6, and 4.3.0, ?LOG_DEBUG("shutting down Shovel '~ts', ... Shovel state: ~tp", [Name, State]) formats the entire state map. The 'uris' field holds plaintext URIs after credentials_obfuscation:decrypt (called in rabbit_shovel_util:deobfuscated_uris/2). No forma
nvd
CVE-2019-11291P4MEDIUMCVSS 4.8≥ 0, < 3.8.3-12019-11-22
CVE-2019-11291 [MEDIUM] CVE-2019-11291: Pivotal RabbitMQ, 3 Pivotal RabbitMQ, 3.7 versions prior to v3.7.20 and 3.8 version prior to v3.8.1, and RabbitMQ for PCF, 1.16.x versions prior to 1.16.7 and 1.17.x versions prior to 1.17.4, contain two endpoints, federation and shovel, which do not properly sanitize user input. A remote authenticated malicious user with administrative access could craft a cross site scripting attack via the vhost or node name fields that could grant access to virtual hos
osv
CVE-2026-44839P4MEDIUMCVSS 4.8v>= 3.7.0, < 4.0.13v>= 4.1.0-alpha, < 4.1.22026-05-27
CVE-2026-44839 [MEDIUM] CWE-80 CVE-2026-44839: RabbitMQ is a messaging and streaming broker. From 3.7.0 to before 4.1.2 and 4.0.13, This vulnerabi RabbitMQ is a messaging and streaming broker. From 3.7.0 to before 4.1.2 and 4.0.13, This vulnerability is fixed in 4.1.2 and 4.0.13.
nvd
CVE-2014-9649P4MEDIUMCVSS 4.3≥ 0, < 3.4.1-12015-01-27
CVE-2014-9649 [MEDIUM] CVE-2014-9649: Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2 Cross-site scripting (XSS) vulnerability in the management plugin in RabbitMQ 2.1.0 through 3.4.x before 3.4.1 allows remote attackers to inject arbitrary web script or HTML via the path info to api/, which is not properly handled in an error message.
osv
CVE-2026-66069P4LOWCVSS 2.3v>= 4.1.0, < 4.1.13v>= 4.2.0, < 4.2.72026-09-23
CVE-2026-66069 [LOW] CWE-862 CVE-2026-66069: RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.13, 4.2.7, and 4.3.0, is_authori RabbitMQ is a messaging and streaming broker. Prior to versions 4.1.13, 4.2.7, and 4.3.0, is_authorized/2 uses is_authorized_monitor for all methods. DELETE resets rabbit_core_metrics:reset_auth_attempt_metrics(). Impact is cosmetic (counters only, no log erasure), but inconsistent with rabbit_mgmt_wm_reset.erl which requires admin for the analogous op
nvd
CVE-2026-67240P4LOWCVSS 2.3v>= 4.2.0, < 4.2.7v>= 4.3.0, < 4.3.12026-09-23
CVE-2026-67240 [LOW] CWE-1333 CVE-2026-67240: RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, pattern_to_regex ma RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, pattern_to_regex maps % -> .*? and _ -> ., then compiles ^...$ with only [unicode]; re:run is called with only [{capture, none}] - no explicit match_limit. A pattern like %_%_..._%X becomes ^.*?..*?.....*?.X$ with overlapping lazy quantifiers. The whole-expression cap is
nvd
CVE-2015-0862P4LOWCVSS 3.5≥ 0, < 3.4.3-12015-01-18
CVE-2015-0862 [LOW] CVE-2015-0862: Multiple cross-site scripting (XSS) vulnerabilities in the management web UI in the RabbitMQ management plugin before 3 Multiple cross-site scripting (XSS) vulnerabilities in the management web UI in the RabbitMQ management plugin before 3.4.3 allow remote authenticated users to inject arbitrary web script or HTML via (1) message details when a message is unqueued, such as headers or arguments; (2) policy names, which are not properly handled when viewing polic
osv
Rabbitmq Rabbitmq-Server vulnerabilities | cvebase