Thephpleague Flysystem vulnerabilities
2 known vulnerabilities affecting thephpleague/flysystem.
Total CVEs
2
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
HIGH1LOW1
Vulnerabilities
Page 1 of 1
CVE-2021-32708P3HIGHCVSS 8.1≥ 1.0.0, < 1.1.4≥ 2.0.0, < 2.1.1+2 more2021-06-24
CVE-2021-32708 [HIGH] CWE-367 CVE-2021-32708: Flysystem is an open source file storage library for PHP. The whitespace normalisation using in 1.x
Flysystem is an open source file storage library for PHP. The whitespace normalisation using in 1.x and 2.x removes any unicode whitespace. Under certain specific conditions this could potentially allow a malicious user to execute code remotely. The conditions are: A user is allowed to supply the path or filename of an uploaded file, the supplied path
nvd
CVE-2026-102601P4LOWCVSS 3.5fixed in 3.35.32026-09-29
CVE-2026-102601 [LOW] CWE-150 CVE-2026-102601: Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePat
Flysystem is an open source file storage library for PHP. Prior to 3.35.3, the default WhitespacePathNormalizer in src/WhitespacePathNormalizer.php used by Filesystem across adapters calls preg_match with the u modifier and treats both false and 0 as falsy. A path containing malformed UTF-8 causes PCRE to return false, so paths that also contain cont
nvd