CVE-2026-103552
published 2026-10-02CVE-2026-103552: Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the…
PriorityP347high7.3CVSS 3.1
AVNACLPRNUINSUCLILAL
EPSS
0.34%
26.4th percentile
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
Affected
1 ranges
| Vendor | Product | Version range | Fixed in |
|---|---|---|---|
| apache_software_foundation | apache_directory_ldap_api | >= 1.2.0 < 1.2.9 | 1.2.9 |
CVSS provenance
nvdv3.17.3HIGHCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
vendor_redhat7.3HIGH
Stop checking back — get the weekly exploitation signal.
Every Monday: what got weaponized or added to CISA KEV in the last seven days — each CVE cross-linked to its PoC, Nuclei template, and detection rule. Free, one email a week, unsubscribe in one click.
Red Hat
org.apache.directory.api/api-ldap-codec-core: Apache Directory LDAP API: Denial of Service via deeply nested search filter
vendor_redhat·2026-10-02·CVSS 7.3
CVE-2026-103552 [HIGH] CWE-770 org.apache.directory.api/api-ldap-codec-core: Apache Directory LDAP API: Denial of Service via deeply nested search filter
org.apache.directory.api/api-ldap-codec-core: Apache Directory LDAP API: Denial of Service via deeply nested search filter
A flaw was found in Apache Directory LDAP API. An unauthenticated remote attacker can cause a Denial of Service (DoS) by submitting a deeply nested search filter before authenticating (binding) with the server. Processing this filter triggers a stack overflow in the server decoder, resulting in an application crash.
Package: api-ldap-codec-core (Red Hat Fuse 7) - Affected
GHSA
Stack Overflow vulnerability in Apache Directory LDAP API.
ghsa_unreviewed·2026-10-02
CVE-2026-103552 [HIGH] CWE-121 Stack Overflow vulnerability in Apache Directory LDAP API.
Stack Overflow vulnerability in Apache Directory LDAP API.
Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder.
This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9.
Users are recommended to upgrade to version 1.2.9, which fixes the issue.
No detection rules found.
No public exploits indexed.
2026-10-02
Published