cbcvebase.

Apache Software Foundation Apache Directory Ldap Api vulnerabilities

7 known vulnerabilities affecting apache_software_foundation/apache_directory_ldap_api.

Total CVEs
7
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL1HIGH6

Vulnerabilities

Page 1 of 1
CVE-2026-103877P2CRITICALCVSS 9.8≥ 2.1.0, < 2.1.92026-10-02
CVE-2026-103877 [CRITICAL] CWE-502 CVE-2026-103877: Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue/compromised LDAP server (or pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object that contains a serialized Java class, allowing some potential RCE. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. User
nvd
CVE-2026-35563P3HIGHCVSS 8.5≥ 2.0.0, ≤ 2.1.72026-06-01
CVE-2026-35563 [HIGH] CWE-297 CVE-2026-35563: It was identified that the LDAP client implementation in version 2.1.7 does not verify if the server It was identified that the LDAP client implementation in version 2.1.7 does not verify if the server certificate matches the intended LDAP hostname. While the underlying code validates the certificate chain against a trusted authority, the absence of endpoint identification allows a valid certificate issued for an entirely unrelated host to be imprope
nvd
CVE-2026-103552P3HIGHCVSS 7.3≥ 1.2.0, < 1.2.92026-10-02
CVE-2026-103552 [HIGH] CWE-121 CVE-2026-103552: Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a de Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.
nvd
CVE-2026-103880P3HIGHCVSS 7.5≥ 2.1.0, < 2.1.92026-10-02
CVE-2026-103880 [HIGH] CWE-405 CVE-2026-103880: Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. Storing a password us Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. Storing a password using the bcrypt algorithm with a high force like 30 in a LDAP server that supports this algorithm will cause the server CPU to run for hours checking the credentials. A bounded cost should be enforced to avoid a server DOS. This issue affects Apache Dire
nvd
CVE-2026-102731P3HIGHCVSS 7.5≥ 1.2.0, < 1.2.92026-10-02
CVE-2026-102731 [HIGH] CWE-789 CVE-2026-102731: Memory allocation with excessive size value vulnerability in Apache Directory LDAP API. A malicio Memory allocation with excessive size value vulnerability in Apache Directory LDAP API. A malicious peer (or a MITM) can send a small BER-encoded response causing a large memory allocation before any data is received. This can lead to an OutOfMemoryError and denial of service. The client JVM OOMs (OutOfMemoryError bypasses the DecoderException hand
nvd
CVE-2026-103885P3HIGHCVSS 7.5≥ 2.1.0, < 2.1.92026-10-02
CVE-2026-103885 [HIGH] CWE-400 CVE-2026-103885: Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. A LDAP server using t Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. A LDAP server using the LDAP API (like Apache DS) may consume 100% of a CPU core indefinitely when processing some badly crafted Telephone Numbers. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9, wh
nvd
CVE-2026-103878P3HIGHCVSS 7.5≥ 2.1.0, < 2.1.92026-10-02
CVE-2026-103878 [HIGH] CWE-345 CVE-2026-103878: Cleartext transmission of sensitive information vulnerability in Apache Directory LDAP API. A Sta Cleartext transmission of sensitive information vulnerability in Apache Directory LDAP API. A StartTLS extended operation started after a Search request has been sent can lead to receive data in plain text before the TLS Handshake has been completed. This issue affects Apache Directory LDAP API: from 2.1.0 before 2.1.9. Users are recommended to u
nvd
Apache Software Foundation Apache Directory Ldap Api vulnerabilities | cvebase