cbcvebase.

Apache Software Foundation Apache Doris vulnerabilities

11 known vulnerabilities affecting apache_software_foundation/apache_doris.

Total CVEs
11
CISA KEV
0
Public exploits
0
Exploited in wild
0
Severity breakdown
CRITICAL3HIGH4MEDIUM4

Vulnerabilities

Page 1 of 1
CVE-2026-58319P2CRITICALCVSS 9.1≥ 2.1.0, < 3.1.02026-07-14
CVE-2026-58319 [CRITICAL] CWE-306 CVE-2026-58319: Certain Apache Doris FE HTTP REST administrative APIs were accessible without proper authentication. Certain Apache Doris FE HTTP REST administrative APIs were accessible without proper authentication. An unauthenticated attacker with network access to the FE HTTP service could perform unauthorized administrative operations, potentially affecting cluster integrity and availability and leading to cluster instability or denial of service. This iss
nvd
CVE-2024-27438P3CRITICALCVSS 9.8≥ 1.2.0, ≤ 2.0.42024-03-21
CVE-2024-27438 [CRITICAL] CWE-494 CVE-2024-27438: Download of Code Without Integrity Check vulnerability in Apache Doris. The jdbc driver files used f Download of Code Without Integrity Check vulnerability in Apache Doris. The jdbc driver files used for JDBC catalog is not checked and may resulting in remote command execution. Once the attacker is authorized to create a JDBC catalog, he/she can use arbitrary driver jar file with unchecked code snippet. This code snippet will be run when catalog
nvd
CVE-2026-72524P3HIGHCVSS 8.8≥ 3.1.0, ≤ 3.1.*≥ 4.0.0, ≤ 4.0.7+1 more2026-09-14
CVE-2026-72524 [HIGH] CWE-863 CVE-2026-72524: Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privile Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access or modify data they are not authorized to. This issue affects Apache Doris: from 3.1.0 through 3.1.*, from 4.0.0 through 4.0.7, and from 4.1.0 through 4.1.3. Users are recommended to upgrade to a fixed release (4.0.8 or 4.1.4),
nvd
CVE-2026-31377P3HIGHCVSS 7.5≥ 2.0.0, < 4.0.8≥ 4.1.0, < 4.1.42026-09-23
CVE-2026-31377 [HIGH] CWE-287 CVE-2026-31377: An Improper Authentication vulnerability in the Apache Doris Frontend (FE) meta service allows an un An Improper Authentication vulnerability in the Apache Doris Frontend (FE) meta service allows an unauthenticated remote attacker to access internal metadata service endpoints. The affected endpoints relied on client-supplied node information for authentication without providing sufficient authentication of the requesting party. Under certain networ
nvd
CVE-2023-41314P3HIGHCVSS 8.2≥ 1.2.0, ≤ 2.0.32023-12-18
CVE-2023-41314 [HIGH] CWE-863 CVE-2023-41314: The api /api/snapshot and /api/get_log_file would allow unauthenticated access. It could allow a DoS The api /api/snapshot and /api/get_log_file would allow unauthenticated access. It could allow a DoS attack or get arbitrary files from FE node. Please upgrade to 2.0.3 to fix these issues.
nvd
CVE-2023-41313P3CRITICALCVSS 9.8fixed in 1.2.82024-03-12
CVE-2023-41313 [CRITICAL] CWE-208 CVE-2023-41313: The authentication method in Apache Doris versions before 2.0.0 was vulnerable to timing attacks. Us The authentication method in Apache Doris versions before 2.0.0 was vulnerable to timing attacks. Users are recommended to upgrade to version 2.0.0 + or 1.2.8, which fixes this issue.
nvd
CVE-2022-23942P3HIGHCVSS 7.5v0.15.02022-04-26
CVE-2022-23942 [HIGH] CWE-798 CVE-2022-23942: Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap pas Apache Doris, prior to 1.0.0, used a hardcoded key and IV to initialize the cipher used for ldap password, which may lead to information disclosure.
nvd
CVE-2026-96443P3MEDIUMCVSS 6.5≥ 2.0.5, ≤ 4.1.32026-09-23
CVE-2026-96443 [MEDIUM] CWE-829 CVE-2026-96443: Insufficient validation of the JDBC driver URL in Apache Doris allows a privileged user to achieve r Insufficient validation of the JDBC driver URL in Apache Doris allows a privileged user to achieve remote code execution on the FE.
nvd
CVE-2026-68570P3MEDIUMCVSS 6.5≥ 2.0.0, ≤ 2.1.*≥ 3.0.0, ≤ 3.0.*+2 more2026-09-14
CVE-2026-68570 [MEDIUM] CWE-863 CVE-2026-68570: Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privile Incorrect Authorization vulnerability in Apache Doris allows an authenticated user to bypass privilege checks and access data they are not authorized to read, resulting in unauthorized disclosure of information. This issue affects Apache Doris: from 2.0.0 through 2.1.*, from 3.0.0 through 3.0.*, from 4.0.0 before 4.0.8, and from 4.1.0 before 4.1.4
nvd
CVE-2024-48019P4MEDIUMCVSS 5.4≥ 2.1.0, < 2.1.8≥ 3.0.0, < 3.0.32025-02-04
CVE-2024-48019 [MEDIUM] CWE-22 CVE-2024-48019: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Files or Directories Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal'), Files or Directories Accessible to External Parties vulnerability in Apache Doris. Application administrators can read arbitrary files from the server filesystem through path traversal. Users are recommended to upgrade to version 2.1.8, 3.0.3 or later, which fixes the
nvd
CVE-2024-26307P4MEDIUMCVSS 5.3fixed in 1.2.8fixed in 2.0.42024-03-21
CVE-2024-26307 [MEDIUM] CWE-362 CVE-2024-26307: Possible race condition vulnerability in Apache Doris. Some of code using `chmod()` method. This met Possible race condition vulnerability in Apache Doris. Some of code using `chmod()` method. This method run the risk of someone renaming the file out from under user and chmodding the wrong file. This could theoretically happen, but the impact would be minimal. This issue affects Apache Doris: before 1.2.8, before 2.0.4. Users are recommended to up
nvd
Apache Software Foundation Apache Doris vulnerabilities | cvebase